hdu 1043 Eight(A*)

Eight

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25251    Accepted Submission(s): 6726
Special Judge


Problem Description
The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as: 
 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle: 
 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
            r->            d->            r->

The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively. 

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and 
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course). 

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three 
arrangement.
 

Input
You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle 

1 2 3 
x 4 6 
7 5 8 

is described by this list: 

1 2 3 x 4 6 7 5 8
 

Output
You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.
 

Sample Input
  
  
2 3 4 1 5 x 7 6 8
 

Sample Output
  
  
ullddrurdllurdruldr

   
   

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<queue>
#define N 400005
using namespace std;
typedef long long ll;
const int M=1e9+7;
struct node{
    int f[3][3],x,y,g,h,hashk;
    bool operator < (const node a)const{
        return h==a.h?g>a.g:h>a.h;
    }
};
int ha[9]={1,1,2,6,24,120,720,5040,40320};
int u[]={-1,1,0,0};
int v[]={0,0,-1,1};
char c[]="udlr",s[N];
int pre[N],ji[N];
int get_hash(node e)//康托展开,压缩空间,根据逆序对的个数
{
    int a[9],i,j,k=0,ans=0;
    for(i=0;i<3;i++)
        for(j=0;j<3;j++)
            a[k++]=e.f[i][j];
    for(i=0;i<9;i++)
    {
        k=0;
        for(j=0;j<i;j++)
            if(a[j]>a[i])k++;
        ans+=ha[i]*k;
    }
    return ans;
}
int get_h(node e)//与目标位之差
{
    int i,j,ans=0;
    for(i=0;i<3;i++)
    {
        for(j=0;j<3;j++)
        {
            if(e.f[i][j])
            ans+=abs(i-(e.f[i][j]-1)/3)+abs(j-(e.f[i][j]-1)%3);
        }
    }
    return ans;
}
void bfs(node src,int to)
{
    memset(ji,0,sizeof(ji));
    src.hashk=get_hash(src);
    src.g=0;
    src.h=get_h(src);
    ji[src.hashk]=1;
    pre[src.hashk]=-1;
    if(src.hashk==to)return;
    priority_queue<node>Q;
    Q.push(src);
    while(!Q.empty())
    {
        node p=Q.top();
        Q.pop();
        for(int i=0;i<4;i++)
        {
            node now=p;
            now.x+=u[i];
            now.y+=v[i];
            if(now.x<0||now.x>=3||now.y<0||now.y>=3)continue;
            swap(now.f[p.x][p.y],now.f[now.x][now.y]);
            now.hashk=get_hash(now);
            if(ji[now.hashk])continue;
            ji[now.hashk]++;
            now.g++;
            now.h=get_h(now);
            pre[now.hashk]=p.hashk;
            s[now.hashk]=c[i];
            if(now.hashk==to)return;
            Q.push(now);
        }
    }
}
void print(int p)
{
    if(pre[p]==-1)return;
    print(pre[p]);
    printf("%c",s[p]);
}
int main ()
{
    char a[30];
    node to;
    for(int i=0;i<9;i++)
        to.f[i/3][i%3]=(i+1)%9;
    to.hashk=get_hash(to);
    while(gets(a))
    {
        int k=0,n;
        node e;
        n=strlen(a);
        for(int i=0,j=0;i<n;i++)
        {
            if(a[i]==' ')continue;
            if(a[i]=='x'){
                e.f[j/3][j%3]=0;
                e.x=j/3;
                e.y=j%3;
            }
            else e.f[j/3][j%3]=a[i]-'0';
            j++;
        }
        //判断逆序数
        for(int i=0;i<9;i++)
        {
            if(e.f[i/3][i%3]==0)continue;
            for(int j=0;j<i;j++)
            {
                if(e.f[j/3][j%3]==0)continue;
                if(e.f[j/3][j%3]>e.f[i/3][i%3])k++;
            }
        }
        if(k&1)printf("unsolvable\n");
        else {
            bfs(e,to.hashk);
            print(to.hashk);
            printf("\n");
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值