Cleaning Shifts(POJ - 2376)

Cleaning Shifts

 POJ - 2376 

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

思路:

  • 贪心
  • 按奶牛空闲时间开始的时间进行排序,在开始时间满足小于等于一个起始时间(起始时间初始化为1)的条件下尽量选择结束时间较靠后的点
  • 选择好一个结束时间最靠后的区间后,将起始时间更新为结束时间+1,然后循环重复如上的判断
  • 注意:Integer.max(int,int)是JDK1.8才有的东西,会编译错误,应该使用Math.max(int,int)

AcCode:

import java.util.Arrays;
import java.util.Scanner;

import static java.lang.Math.max;

public class Main {
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		int N = in.nextInt();
		int T = in.nextInt();
		Job[] jobs = new Job[N];
		for (int i = 0; i < jobs.length; i++) {
			jobs[i] = new Job(in.nextInt(), in.nextInt());
		}
		
		Arrays.sort(jobs);
		
		int beginTime = 1;
		int endTime = -1;
		int count = 1;
		
		for (int i = 0; i < jobs.length; i++) {
			int s = jobs[i].beginTime;
			int e = jobs[i].endTime;
			
			if(i==0 && s>1)break;
			
			if(s<=beginTime) {
				endTime = max(endTime, e);
			}else {
				count++;//更新区间
				beginTime = endTime+1;
				if(s<=beginTime) {
					endTime = max(endTime, e);
				}else {
					break;
				}
			}
			
			if(endTime>=T) {
				break;
			}
		}
		
		if(endTime<T) {
			System.out.println(-1);
		}else {
			System.out.println(count);
		}
	}
	
	private static class Job implements Comparable<Job>{
		int beginTime;
		int endTime;
		
		public Job(int beginTime,int endTime) {
			this.beginTime = beginTime;
			this.endTime = endTime;
		}

		@Override
		public int compareTo(Job o) {
			int res = beginTime-o.beginTime;
			if(res==0) {
				return endTime-o.endTime;
			}else {
				return res;				
			}
		}
		
		@Override
		public String toString() {
			// TODO Auto-generated method stub
			return beginTime+" "+endTime;
		}
		
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值