Maximum GCD

 

 Maximum GCD

Given the N integers, you have to find the maximum GCD (greatest common divisor) of every possible pair of these integers.

Input

The first line of input is an integer N (1 < N < 100) that determines the number of test cases. The following N lines are the N test cases. Each test case contains M (1 < M < 100) positive integers that you have to find the maximum of GCD.

Output

For each test case show the maximum GCD of every possible pair.

Sample Input

3

10 20 30 40

7 5 12

125 15 25

Sample Output

20

1

25

题的大意是在所给出n个数任意选两个数,求这两个数的最大公因数,最后求最大的最大公因数。

这道题是一个水题但是输入输出是最大的坑,比如一次性输入多个空格啦。。。。。。

ac代码

#include <iostream>
#include <string>
#include <cmath>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;

int gcd(int x,int y)
{
    if(x==0)
        return y;
    else
        return gcd(y%x,x);
}
int main()
{
    int i, j;
    int a;
    cin >> a;
    getchar();
    while(a--)
    {
        int ans[101], cns = 0, maxn = 1;
        char c;
        while((c=getchar())!='\n')
       {
          if (c >= '0' && c <= '9') {
               ungetc(c,stdin);
                scanf("%d",&ans[cns++]);
            }
       }
       for(i = 0; i < cns; i++)
        for(j = 0; j < cns; j++)
        {
            for(i = j + 1; i < cns; i++)
            {
                maxn=max(maxn,gcd(ans[i],ans[j]));
            }
        }
        cout << maxn <<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值