POJ 2255 二叉树遍历 已知前序遍历 中序遍历 求后序遍历

Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:
 D 
                                              / \

                                             /   \

 B     E 
                                           / \     \

                                          /   \     \

 A     C     G 
                                                    /

                                                   /

 F 

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!

Input

The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB
 
  
题意就是 给你二叉树的前序遍历 中序遍历 求后序遍历  
 
  
这个是二叉树 后序遍历的应用  注意数组的区间变化 从根节点一点点向下递推 然后再一点点的输出节点
 
  
代码如下
 
  
#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std ;
char preorder[30] = {'\0'} , inorder[30] = {'\0'};
int len ;
//函数中的参数为前序和中序遍历所对应的数组区间下标
void build(int prel , int prer ,int inl , int inr)
{
	if(prel > prer) return ;
	char temp = preorder[prel] ;
	int num ;
	//在中序遍历结果中找前序遍历的节点位置,以此来划分递归区间
	for(int i = inl ; i <= inr ; i ++)
	{
		if(inorder[i] == temp)
		{
			num = i - inl ;
			break ;
		}
	}
	build(prel + 1 , prel + num , inl , inl + num-1) ;//左子树
	build(prel + 1 + num , prer , inl + num + 1 , inr) ;//右子树
	cout << temp ;
}
int main()
{
	while(cin >> preorder >> inorder)
	{
		len = strlen(preorder) ;
		build(0 , len - 1 , 0 , len - 1) ;
		cout << endl ;
	}
	return 0;
}

顺便感慨一下 C++比C好写的多
 
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值