poj 1068 模拟水题

2 篇文章 0 订阅

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6

1 1 2 4 5 1 1 3 9

题意:P ‘)’前‘(’ 的数目

Q “()”之间‘()’的数目(算上自己)

思路:注意一下 题目上说的是n<20 其实不只 我n开到1000就过了 还有 输出最后一行有空格 垃圾题

可以吧‘(’看成1 ‘)’看成0 然后构造01字符串

计算Q的时候可以从0入手 向前读 读到0就0加一 读到1就 0减一 sum++ 0的数目为0是时 跳出循环就好

代码:

#include<iostream>
#include<cstdio>
#include<cstring>

int main()
{
    int t;
    int a[1000] ;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int dis = 0;
          int dis1 = 0;
        for(int i = 0; i < n; i++)//构建0 1字符串
        {

            int s;
            scanf("%d",&s);
            while(dis1 < s)
            {
                a[dis++] = 1;
                dis1++;
            }
            a[dis++] = 0;
        }
        for(int i = 0;i < dis; i++)//计算Q
        {
            int sum = 0;
            int dis2 = 0;
            if(a[i] == 0)
            {

                for(int k = i; k >= 0; k--)
                {
                    if(a[k] == 1)
                    {
                        dis2--;
                        sum++;
                    }
                    if(a[k] == 0)
                        dis2++;
                    if(dis2 == 0)
                        break;
                }
            }
            if(sum != 0)
             {
                 printf("%d ",sum);
             }
        }
        printf("\n");

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值