poj-1068 Parencodings

7 篇文章 0 订阅

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

   题意: P表示的是当前位置前有几个左括号‘(’,当前位置有一个右括号‘)’,W表示的是当前位置下一对括号”()“中有几对括号(包括自身),S为实际的括号情况。方法是将括号数组用‘1’‘0’表示出来1为左0为右,在输入P的时候构建括号模拟数组,构建一次就从当前位置开始向前遍历,设一个累加器x,遇到右括号累加器x+1,遇到左括号累加器x-1并且sum累加器+1表示出现一对括号,当x=0时停止遍历,将sum值存入答案数组中。最后输出答案数组。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <algorithm>
#include <iostream>

using namespace std;

int main()
{
    int arr[1000];
    int ans[100];
    int t,n,a,b,j,m;
    int x,sum;
    scanf("%d",&t);
    while (t--)
    {
        int top=0;b=0;
        int i=0;
        scanf("%d",&n);
        while (n--)
        {
            scanf("%d",&a);
            m=a-b;
            while(m--)
            {
                arr[i++]=1;
            }
            arr[i++]=0;
            b=a;
            x=0;sum=0;
            for (j=i-1;j>=0;j--)
            {
                if(arr[j])
                {
                    x--;
                    sum++;
                }
                else x++;
                if(x==0)
                {
                    ans[top++]=sum;
                    break;
                }
            }
        }
        for (i=0;i<top;i++)
        {
            printf("%d%c",ans[i],i==top-1?'\n':' ');
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值