hdu 5015 矩阵快速幂

12 篇文章 3 订阅
7 篇文章 0 订阅

233 Matrix

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2722    Accepted Submission(s): 1572


Problem Description
In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333... (it means a 0,1 = 233,a 0,2 = 2333,a 0,3 = 23333...) Besides, in 233 matrix, we got a i,j = a i-1,j +a i,j-1( i,j ≠ 0). Now you have known a 1,0,a 2,0,...,a n,0, could you tell me a n,m in the 233 matrix?
 

Input
There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 10 9). The second line contains n integers, a 1,0,a 2,0,...,a n,0(0 ≤ a i,0 < 2 31).
 

Output
For each case, output a n,m mod 10000007.
 

Sample Input
 
 
1 1 1 2 2 0 0 3 7 23 47 16
 

Sample Output
 
 
234 2799 72937
Hint
题意:构建一个矩阵 啊a(0,0) = 0; a(n,0)由键盘输入 a(0,1)=233 a(0,2)=2333 a(0,3)=23333......; a(i,j)=a(i-1.j)+a(i,j-1)
求a(n,m)
很典型的一个矩阵快速幂的题
最重要的是推导出快速幂的矩阵

思路:

第一列元素为:

0

a1

a2

a3

a4

转化为:

23

a1

a2

a3

a4

3

则第二列为:

23*10+3

23*10+3+a1

23*10+3+a1+a2

23*10+3+a1+a2+a3

23*10+3+a1+a2+a3+a4

3

根据前后两列的递推关系,有等式可得矩阵A的元素为
其中a(0,0)=23
ac代码
#include<iostream>
#include<cstdio>
#include<cstring>
#define MOD 10000007
using namespace std;

typedef long long LL;

int n,m;
//矩阵结构体
struct Mat
{
    LL mat[15][15];
};
//乘法模板
Mat operator*(Mat a,Mat b)
{
        Mat c;
        memset(c.mat,0,sizeof(c.mat));
        for(int k = 0; k < n+2;k++)
            for(int i = 0; i < n+2; i++)
            for(int j = 0; j < n+2; j++)
            c.mat[i][j] = (c.mat[i][j] + a.mat[i][k]*b.mat[k][j])%MOD;
        return c;
}

int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        Mat sum,temp;
        memset(sum.mat,0,sizeof(sum.mat));
        memset(temp.mat,0,sizeof(temp.mat));
        sum.mat[0][0] = 23;
        sum.mat[n+1][0] = 3;
        for(int i = 1; i < n+1; i++)
            scanf("%lld",&sum.mat[i][0]);
        if(m == 0)
        {
            if(n == 0)
            printf("0\n");
            else
                printf("%lld\n",sum.mat[n][0]);
        }
        else
        {
            //构建快速幂矩阵
            for(int i = 1; i <= n; i++)
            {
                for(int j = 1; j <= i; j++)
                {
                    temp.mat[i][j] = 1;
                }
            }
            for(int i = 0; i < n+2; i++)
                temp.mat[i][0] = 10;
            for(int i = 0; i < n+2; i++)
                temp.mat[n+1][i] = 0;
              for(int i = 0; i < n+2; i++)
                temp.mat[i][n+1] = 1;
            Mat res;
            memset(res.mat,0,sizeof(res.mat));
            for(int i = 0; i < n+2; i++)
                res.mat[i][i] = 1;
                //m次方
            while(m>0)
            {
                if(m&1)
                    res = res*temp;
                temp = temp*temp;
                m/=2;
            }
        sum = res*sum;//特别注意这里  是和res相乘
            printf("%lld\n",sum.mat[n][0]);
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值