poj2488 A Knight's Journey

12 篇文章 0 订阅


Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4


题意:给你国际象棋棋盘的大小 问你马从其中一格出发能不能走完所有的格子

如果可以按字典序输出经过的路径


一个dfs很简单的题  但是要输出路径  那么马走的顺序就要按着字典序 这个弄清楚之后就会很简单了


ac代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>

using namespace std;

int p,q;
int cnt;
int sum;
int flag;

int m[30][30];

char str1[100];
int str2[100];

int dx[10]={-2,-2,-1,-1,1,1,2,2};
int dy[10]={-1,1,-2,2,-2,2,-1,1};

void dfs(int xx,int yy)
{
    if(flag == 1)
        return ;

    if(m[xx][yy] == 0)
    {

        str1[cnt] = 65+xx;
        str2[cnt] = yy+1;
       
        cnt++;
        m[xx][yy] = 1;
        if(cnt == sum)
        {
            flag = 1;
            return ;
        }
        for(int i = 0; i < 8; i++)
        {
            if(xx+dx[i] >=0 && xx+dx[i] < q)
                if(yy+dy[i] >= 0 && yy+dy[i] < p)
                    dfs(xx+dx[i],yy+dy[i]);

        }
        cnt--;//8种情况都不能接着向下走的时候,返回上一步
        m[xx][yy] = 0;//当前的位置重置

    }
    else
        return ;


}

int main()
{

    int n;
    while(~scanf("%d",&n))
    {
        for(int i = 0; i < n; i++)
        {
            scanf("%d %d",&p,&q);

            printf("Scenario #%d:\n",i+1);
            memset(m,0,sizeof(m));
            sum = p*q;

            flag = 0;
            for(int j = 0; j < p; j++)
                for(int k = 0; k < q; k++)
                {

                    cnt = 0;
                    dfs(k,j);
                    if(flag == 1)
                        break;
                }
            if(flag == 0)
            {
                printf("impossible\n");
            }
            else
            {
                for(int j = 0; j < sum; j++)
                {
                    printf("%c",str1[j]);
                    printf("%d",str2[j]);
                }
                printf("\n");
            }
            printf("\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值