poj1837 Balance

9 篇文章 0 订阅

Balance
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 15707 Accepted: 9901

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2


题意:一个天平;给你钩子的位置、数目,砝码的位置、数目,问你使天平平衡的挂法有多少种


思路:如果把天平的平衡情况用数值来表示,那么挂上砝码的话就改变了天平的平衡状态,即天平状态发生了改变

这样就变成了一个dp的题目;

我们把天平的状态用数值 j 表示,

当平衡度j=0时,说明天枰达到平衡,j>0,说明天枰倾向右边(x轴右半轴),j<0则相反

那么此时可以把平衡度j看做为衡量当前天枰状态的一个值

因此可以定义一个 状态数组dp[i][j],意为在挂满前i个钩码时,平衡度为j的挂法的数量。

由于距离c[i]的范围是-15~15,钩码重量的范围是1~25,钩码数量最大是20

因此最极端的平衡度是所有物体都挂在最远端,因此平衡度最大值为j=15*20*25=7500。原则上就应该有dp[ 1~20 ][-7500 ~ 7500 ]。

因此为了不让下标出现负数,做一个处理,使使得数组开为 dp[1~20][0~15000],则当j=7500时天枰为平衡状态


那么每次挂上一个钩码后,对平衡状态的影响因素就是每个钩码的 力臂

力臂=重量 *臂长 = w[i]*c[k]

那么若在挂上第i个砝码之前,天枰的平衡度为j

   (换言之把前i-1个钩码全部挂上天枰后,天枰的平衡度为j)

则挂上第i个钩码后,即把前i个钩码全部挂上天枰后,天枰的平衡度 j=j+ w[i]*c[k]

   其中c[k]为天枰上钩子的位置,代表第i个钩码挂在不同位置会产生不同的平衡度


假设 dp[i-1][j] 的值已知,设dp[i-1][j]=num

 (即已知把前i-1个钩码全部挂上天枰后得到状态j的方法有num次)

那么它的下一个状态 即挂上第 i 个钩子 位置为 k 的时候

dp[i][j+w[i]*c[k]] = dp[i-1][j] = num;

因为不同的前一种状态会打到相同的下一种状态

所以dp[i][j+w[i]*c[k]] = ∑dp[i-1][j];


所以状态转移方程 dp[i][j+w[i]*c[k]] += dp[i-1][j] ; 


初始化:dp[0][7500] = 1;   //不挂任何重物时天枰平衡,此为一个方法


ac代码

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

int dp[25][15005];

int main()
{
    int n,g;
    int c[25];
    int w[25];

    scanf("%d %d",&n,&g);
    for(int i = 1; i <= n; i++)
        scanf("%d",&c[i]);
    for(int i = 1; i <= g; i++)
        scanf("%d",&w[i]);

    memset(dp,0,sizeof(dp));
    dp[0][7500] = 1;

    for(int i = 1; i <= g; i++)
        for(int j = 0; j <= 15000; j++)
            if(dp[i-1][j])//前一状态必须有意义然后才向下一状态进行
                for(int k = 1; k <= n; k++)
                dp[i][j+w[i]*c[k]] += dp[i-1][j];

    printf("%d\n",dp[g][7500]);

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值