HDU 1829 & POJ 2492 A Bug's Life (并查集)

                                                                                A Bug's Life
Time Limit: 10000MSMemory Limit: 65536K
Total Submissions: 23483Accepted: 7638

Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
 
/*
  并查集
  对于输入的两个值s,e,首先判断他们是否是同个集合,如果是,
  则说明出现了与假设矛盾的结果,用bool标记一下。
  否则,将s的相反性别的与e合并,e的相反性别与s合并。
  
  390MS	260K
  */
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define SIZE 2005

using namespace std;

struct node
{
    int fa,opp;
}fat[SIZE];

int Case,n,m;

int find(int x)
{
    if(x != fat[x].fa)
        fat[x].fa = find(fat[x].fa);
    return fat[x].fa;
}


void combine(int x,int y)
{
    int tx = find(x);
    int ty = find(y);
    if(tx != ty)
        fat[tx].fa = ty;
}

int main()
{
    scanf("%d",&Case);
    for(int ca=1; ca<=Case; ca++)
    {
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
        {
            fat[i].fa = i; fat[i].opp = 0;
        }
        bool flag = false;
        int s,e;
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d",&s,&e);
            if(flag)continue;
            if(find(s) == find(e))
                flag = true;
            if(fat[s].opp)
                combine(fat[s].opp,e);
            if(fat[e].opp)
                combine(fat[e].opp,s);
            fat[s].opp = e;
            fat[e].opp = s;
        }
        printf("Scenario #%d:\n",ca);
        if(flag)
            printf("Suspicious bugs found!\n\n");
        else
            printf("No suspicious bugs found!\n\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值