POJ 3689 Labeling Balls (拓扑排序)

Labeling Balls
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 8652Accepted: 2354

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, bN) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4
/*
此题还是比较坑的,特别是样例,完全忽悠人。要求输出的不是标签的排序关系,而是从标签1~N每一个
对应的球的重量。因为要求标签越小对应的球的重量也要尽可能轻,这里就涉及到贪心策略。处理方式就
是记录每一个标签的出度,对于出度为0的进行入队(这里我用优先队列)。每次弹出都把当前可给的
最大重量给它。这样就能保证较轻的球留给后面的较小的标签。

*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#define SIZE 205

using namespace std;

int T,N,M;
int deg[SIZE];
bool vis[SIZE];
int ans[SIZE];
bool cnt[SIZE][SIZE];

bool toposort()
{
	priority_queue <int> Q;
	for(int i=1; i<=N; i++)
		if(!deg[i])
			Q.push(i);
	int Size = N;
	int ct = 0;
	while(!Q.empty())
	{
		int cur = Q.top();
		Q.pop();
		ans[cur] = Size--;
		ct ++;
		for(int i=1; i<=N; i++)
		{
			if(cnt[cur][i])
			{
				--deg[i];
				if(!deg[i])
					Q.push(i);
			}
		}
	}
	if(ct != N)
		return false;
	return true;
}

int main()
{
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&N,&M);
		int s,e;
		memset(deg,0,sizeof(deg));
		memset(cnt,0,sizeof(cnt));
		for(int i=1; i<=M; i++)
		{
			scanf("%d%d",&s,&e);
			if(!cnt[e][s])
			{
				cnt[e][s] = true;
			    deg[s] ++;
			}
		}
		bool flag = toposort();
		if(!flag)
		{
			puts("-1");
			continue;
		}
		for(int i=1; i<N; i++)
			printf("%d ",ans[i]);
		printf("%d\n",ans[N]);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值