Multiplying by Rotation
Multiplying by Rotation |
Warning: Not all numbers in this problem are decimal numbers!
Multiplication of natural numbers in general is a cumbersome operation. In some cases however the product can be obtained by moving the last digit to the front.
Example: 179487 * 4 = 717948
Of course this property depends on the numbersystem you use, in the above example we used the decimal representation. In base 9 we have a shorter example:
17 * 4 = 71 (base 9)
as (9 * 1 + 7) * 4 = 7 * 9 + 1
Input
The input for your program is a textfile. Each line consists of three numbers separated by a space: the base of the number system, the least significant digit of the first factor, and the second factor. This second factor is one digit only hence less than the base. The input file ends with the standard end-of-file marker.
Output
Your program determines for each input line the number of digits of the smallest first factor with the rotamultproperty. The output-file is also a textfile. Each line contains the answer for the corresponding input line.
Sample Input
10 7 4 9 7 4 17 14 12
Sample Output
6 2 4
输入3个数字 分别代表进制, 最后一个数字,要乘的数字。
然后用最后一个数字。一个个推出前一个数字。。直到出现一个数字等于最后一个数。。
推导的过程是这样的。 最后一个数字乘上要乘的数字加上前一个数字产生的进位。取个位数作为前一个数。 反复
#include <stdio.h>
#include <string.h>
int jin, num, mu;
int wei;
int main()
{
while (scanf("%d%d%d", &jin, &num, &mu) != EOF)
{
int nu = num;
wei = 1;
int mod = 0;
while (num * mu + mod != nu)
{
int mo = mod;
mod = (num * mu + mo) / jin;
num = (num * mu + mo) % jin;
wei ++;
}
printf("%d\n", wei);
}
return 0;
}