未uva550(数论)

Multiplying by Rotation

Warning: Not all numbers in this problem are decimal numbers!


Multiplication of natural numbers in general is a cumbersome operation. In some cases however the product can be obtained by moving the last digit to the front.


Example: 179487 * 4 = 717948


Of course this property depends on the numbersystem you use, in the above example we used the decimal representation. In base 9 we have a shorter example:


17 * 4 = 71 (base 9)


as (9 * 1 + 7) * 4 = 7 * 9 + 1

Input

The input for your program is a textfile. Each line consists of three numbers separated by a space: the base of the number system, the least significant digit of the first factor, and the second factor. This second factor is one digit only hence less than the base. The input file ends with the standard end-of-file marker.

Output

Your program determines for each input line the number of digits of the smallest first factor with the rotamultproperty. The output-file is also a textfile. Each line contains the answer for the corresponding input line.

Sample Input

10 7 4
9 7 4
17 14 12

Sample Output

6
2
4

题意:这题看了N久就是不理解题意。。看看力哥的解法吧。。

题意:给出一个进制,一个数的最低位,和别的的一个数,比如10进制,第一个数字的最低位是7,第二个数字是4,
和规矩(XXXXX7 * 4 = 7XXXXX,例子: 179487 * 4 = 717948 )求出第一个数字的最小长度。

看起来很难,其实动笔写写就熟悉打听了。输入k,m,n,本来的数字为s,因为s的最后一位为m,则s*n的最后一位为s*n%k,而s*n%k又是s的倒数第二位,如许又可以策画出ans*n的倒数第二位;因为知道最低位,所以次低位一定是最低位*第二个数�se。以此类推,递归下去即可。
最终条件是,没有进位了,而且乘积+原来的进位==最低位。

以此类推,直到乘积+本来的进位==最低位。

题目就是给出三个数,jinzhi,lastnumber,chengshu.求出在jinzhi进制下最少几位数a使得a*chengshu的值最后一位变成最前一位,其他不变。为了说明问题,还是拿题目说明测试数据来说吧。
179487 * 4 = 717948(10进制)
4*7=28 28!=7 28/10=2 28=8;
4*8+2=34 34!=7 37/10=3 34=4;
4*4+3=19 19!=7 19/10=1 19=9;
4*9+1=37 37!=7 37/10=3 37=7;
4*7+3=31 31!=7 31/10=3 31=1;
4*1+3=7 7==7;(end)
则这个数为179487,6位数,输出6。
就是按照上面模拟即可。
 
 
关键还是看题目的提示。。。
Of course this property depends on the numbersystem you use, in the above example we used the decimal representation. In base 9 we have a shorter example:
17 * 4 = 71 (base 9)
as (9 * 1 + 7) * 4 = 7 * 9 + 1
这里就是解题的方向。。。
#include <iostream>
#include<cstdio>
using namespace std;
int main()
{
 int k,m,n;
 //the base of the number system, the least significant digit of the first factor, and the second factor.
 while(scanf("%d%d%d",&k,&m,&n)!=EOF)//k:进制,m:最后一个数,n:乘数.
 {
  int count=1;
  int s=m*n;
  while(s!=m)
  {
   count++;
   s=s%k*n+s/k;
  }
  printf("%d\n",count);
 }
 return 0;
}
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值