Problem F: Factoring Large Numbers
One of the central ideas behind much cryptography is that factoring large numbers is computationally intensive. In this context one might use a 100 digit number that was a product of two 50 digit prime numbers. Even with the fastest projected computers this factorization will take hundreds of years.
You don't have those computers available, but if you are clever you can still factor fairly large numbers.
Input
The input will be a sequence of integer values, one per line, terminated by a negative number. The numbers will fit in gcc's long long int
datatype. You may assume that there will be at most one factor more than 1000000.
Output
Each positive number from the input must be factored and all factors (other than 1) printed out. The factors must be printed in ascending order with 4 leading spaces preceding a left justified number, and followed by a single blank line.
Sample Input
90 1234567891 18991325453139 12745267386521023 -1
Sample Output
2 3 3 5 1234567891 3 3 13 179 271 1381 2423 30971 411522630413
输入一个数字。输出出它的所有质因数。。这些质因数要小于100W。剩下的除完之后也要输出。。
由于质因数有上限 100W个。 所以一个个除过去。然后如果该值已经剩1了,直接结束。如果到结束后该值不为1
就还要输出该值。。
#include <stdio.h>
#include <string.h>
long long n;
int main()
{
while (scanf("%lld", &n) != EOF && n != -1)
{
for (int i = 2; i <= 1000000; i ++)
{
while (n % i == 0)
{
printf(" %d\n", i);
n /= i;
}
if (n == 1)
break;
}
if (n != 1)
printf(" %lld\n", n);
printf("\n");
}
return 0;
}