``Thymine-Adenine-Adenine-Cytosine-Thymine-Guanine-Cytosine-Cytosine-Guanine-Adenine-Thymine"
Then we can represent the above DNA strand with the string ``TAACTGCCGAT." The biologist Prof. Ahn found that a gene X commonly exists in the DNA strands of five different kinds of animals, namely dogs, cats, horses, cows, and monkeys. He also discovered that the DNA sequences of the gene X from each animal were very alike. See Figure 2.
DNA sequence of gene X | |
Cat: | GCATATGGCTGTGCA |
Dog: | GCAAATGGCTGTGCA |
Horse: | GCTAATGGGTGTCCA |
Cow: | GCAAATGGCTGTGCA |
Monkey: | GCAAATCGGTGAGCA |
Prof. Ahn thought that humans might also have the gene X and decided to search for the DNA sequence of X in human DNA. However, before searching, he should define a representative DNA sequence of gene X because its sequences are not exactly the same in the DNA of the five animals. He decided to use the Hamming distance to define the representative sequence. The Hamming distance is the number of different characters at each position from two strings of equal length. For example, assume we are given the two strings ``AGCAT" and ``GGAAT." The Hamming distance of these two strings is 2 because the 1st and the 3rd characters of the two strings are different. Using the Hamming distance, we can define a representative string for a set of multiple strings of equal length. Given a set of strings S = s1,...,sm of length n , the consensus error between a string y of length n and the set S is the sum of the Hamming distances between y and eachsi in S . If the consensus error between y and S is the minimum among all possible strings y of length n , y is called a consensus string of S. For example, given the three strings ``AGCAT" ``AGACT" and ``GGAAT" the consensus string of the given strings is ``AGAAT" because the sum of the Hamming distances between ``AGAAT" and the three strings is 3 which is minimal. (In this case, the consensus string is unique, but in general, there can be more than one consensus string.) We use the consensus string as a representative of the DNA sequence. For the example of Figure 2 above, a consensus string of gene X is ``GCAAATGGCTGTGCA" and the consensus error is 7.
Input
Output
Sample Input
3 5 8 TATGATAC TAAGCTAC AAAGATCC TGAGATAC TAAGATGT 4 10 ACGTACGTAC CCGTACGTAG GCGTACGTAT TCGTACGTAA 6 10 ATGTTACCAT AAGTTACGAT AACAAAGCAA AAGTTACCTT AAGTTACCAA TACTTACCAA
Sample Output
TAAGATAC 7 ACGTACGTAA 6 AAGTTACCAA 12
题意:输入一堆DNA序列。。然后编写一个DNF序列使它与其他所有DNF序列的hanming距离最小(hanming距离就是根据题目中给的。。两个串之间如果对应位置有一个字符不同距离多1)。。
思路:每一列中。找出字母出现最多次的字母。。存为当前位的DNF。。这样每一列hanming距离都会最小。。
#include <stdio.h>
#include <string.h>
int t;
int n, m;
char map[55][1005];
char out[1005];
int out2;
int sb[4];
int max(int a, int b)
{
if (a > b)
return a;
else
return b;
}
int main()
{
scanf("%d", &t);
while (t --)
{
out2 = 0;
memset(out, 0, sizeof(out));
memset(map, 0, sizeof(map));
scanf("%d%d", &n, &m);
getchar();
for (int i = 0; i < n; i ++)
{
gets(map[i]);
}
for (int i = 0; i < m; i ++)
{
memset(sb, 0, sizeof(sb));
for (int j = 0; j < n; j ++)
{
if (map[j][i] == 'A')
sb[0] ++;
if (map[j][i] == 'C')
sb[1] ++;
if (map[j][i] == 'G')
sb[2] ++;
if (map[j][i] == 'T')
sb[3] ++;
}
int maxx = max(max(sb[0], sb[1]), max(sb[2], sb[3]));
for (int k = 0; k < 4; k ++)
{
if (maxx == sb[k])
{
if (k == 0)
out[i] = 'A';
if (k == 1)
out[i] = 'C';
if (k == 2)
out[i] = 'G';
if (k == 3)
out[i] = 'T';
break;
}
}
out2 += (n - maxx);
}
out[m] = '\0';
printf("%s\n%d\n", out, out2);
}
return 0;
}