DNA Consensus String UVA - 1368 (贪心+字符串处理)

DNA (Deoxyribonucleic Acid) is the molecule which contains the genetic instructions. It consists of four different
nucleotides, namely Adenine, Thymine, Guanine, and Cytosine as shown in Figure 1. If we represent a nucleotide by
its initial character, a DNA strand can be regarded as a long
string (sequence of characters) consisting of the four characters A, T, G, and C. For example, assume we are given some
part of a DNA strand which is composed of the following sequence of nucleotides:
“Thymine-Adenine-Adenine-Cytosine-Thymine-Guanine-CytosineCytosine-Guanine-Adenine-Thymine”
Then we can represent the above DNA strand with the
string “TAACTGCCGAT.”
The biologist Prof. Ahn found that a gene X commonly
exists in the DNA strands of five different kinds of animals,
namely dogs, cats, horses, cows, and monkeys. He also discovered that the DNA sequences of the gene X from each animal
were very alike. See Figure 2.
DNA sequence of gene X
Cat: GCATATGGCTGTGCA
Dog: GCAAATGGCTGTGCA
Horse: GCTAATGGGTGTCCA
Cow: GCAAATGGCTGTGCA
Monkey: GCAAATCGGTGAGCA
Figure 2. DNA sequences of gene X in five animals.
Prof. Ahn thought that humans might also have the gene X and decided to search for the DNA
sequence of X in human DNA. However, before searching, he should define a representative DNA
sequence of gene X because its sequences are not exactly the same in the DNA of the five animals. He
decided to use the Hamming distance to define the representative sequence.
The Hamming distance is the number of different characters at each position from two strings of
equal length. For example, assume we are given the two strings “AGCAT” and “GGAAT.” The Hamming
distance of these two strings is 2 because the 1st and the 3rd characters of the two strings are different.
Using the Hamming distance, we can define a representative string for a set of multiple strings of equal
length. Given a set of strings S = {s1, . . . , sm} of length n, the consensus error between a string y of
length n and the set S is the sum of the Hamming distances between y and each si
in S. If the consensus
error between y and S is the minimum among all possible strings y of length n, y is called a consensus
string of S. For example, given the three strings “AGCAT” “AGACT” and “GGAAT” the consensus string
of the given strings is “AGAAT” because the sum of the Hamming distances between “AGAAT” and the
three strings is 3 which is minimal. (In this case, the consensus string is unique, but in general, there
can be more than one consensus string.) We use the consensus string as a representative of the DNA
sequence. For the example of Figure 2 above, a consensus string of gene X is “GCAAATGGCTGTGCA” and
the consensus error is 7.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test
cases T is given in the first line of the input. Each test case starts with a line containing two integers
m and n which are separated by a single space. The integer m (4 ≤ m ≤ 50) represents the number
of DNA sequences and n (4 ≤ n ≤ 1000) represents the length of the DNA sequences, respectively. In
each of the next m lines, each DNA sequence is given.

Output

Your program is to write to standard output. Print the consensus string in the first line of each case
and the consensus error in the second line of each case. If there exists more than one consensus string,
print the lexicographically smallest consensus string.

Sample Input
3
5 8
TATGATAC
TAAGCTAC
AAAGATCC
TGAGATAC
TAAGATGT
4 10
ACGTACGTAC
CCGTACGTAG
GCGTACGTAT
TCGTACGTAA
6 10
ATGTTACCAT
AAGTTACGAT
AACAAAGCAA
AAGTTACCTT
AAGTTACCAA
TACTTACCAA
Sample Output
TAAGATAC
7
ACGTACGTAA
6
AAGTTACCAA
12

思路:贪心+字符串处理,用二维数组存储多个字符串
代码如下:

#include <bits/stdc++.h>

using namespace std;

const int N = 1005;
char ch[N][N];	//用二维字符数组存储DNA串 
int v[200], ans, n, m;;

char solve(int j)
{
	char c;
	int max = 0;
	memset(v, 0, sizeof(v));
	for (int i=0; i<n; i++)	//按列比较 
	{
		v[ch[i][j]]++;	//统计核苷酸出现次数 
		if (max < v[ch[i][j]])	//如果改核苷酸出现次数更多,则更新数据 
		{
			max = v[ch[i][j]];
			c = ch[i][j];
		}
		else if (max == v[ch[i][j]] && c > ch[i][j])	//如果该核苷酸与当前最多出现的核苷酸出现次数相等,并且字典序更小,也更新 
			c = ch[i][j];
	}
	ans += n-v[c];	//计算距离,总核苷酸数-该核苷酸出现次数=不同的个数 
	return c;
}

int main()
{
	int k;
	cin >> k;
	while (k--)
	{
		ans = 0;	//重置ans 
		cin >> n >> m;
		memset(ch, 0, sizeof(ch));
		for (int i=0; i<n; i++)
			cin >> ch[i];	
		for (int j=0; j<m; j++)
			cout << solve(j);
		cout << endl << ans << endl;
	}
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

风落_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值