HDU_1584 A strange lift:BFS

HDU_1584 A strange lift:BFS

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button “UP” , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button “DOWN” , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can’t go up high than N,and can’t go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button “UP”, and you’ll go up to the 4 th floor,and if you press the button “DOWN”, the lift can’t do it, because it can’t go down to the -2 th floor,as you know ,the -2 th floor isn’t exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button “UP” or “DOWN”?
Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,…kn.
A single 0 indicate the end of the input.
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can’t reach floor B,printf “-1”.
Sample Input
5 1 5
3 3 1 2 5
0
Sample Output
3
题意:电梯每层有一个不同的数字,例如第n层有个数字k,那么这一层只能上k层或下k层,但是不能低于一层或高于n层,给定起点与终点,要求出最少要按几次键。例如,有一个5层的建筑,k1=3,k2=3,k3=1,k4=2,k5=5。从1楼开始,一楼数字是3,你可以按“向上”按钮,然后你就上到1+3楼,如果你按“向下”按钮,那你就腻害了。

如果没有学过BFS请直接百度,或者看书;

  • 这一题用的是BFS查找,就是把下一层可以到达的楼层都列出来。
  • 在列出的时候要注意如果遇到曾经列过的楼层就不管他,遇到没有列到的就列出下面几个可能性。
    下面是AC代码;
    我这里使用的是结构体,y来记录最小的被搜到的步数;x表示移动数;
    看起来应该比较简单;
#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <queue>
#include <algorithm>
#include<cstdio>
using namespace std;
int be, en;
int m;
int fl,num;
struct w
{
	int x;
	int y;
}bi[201];
void what()
{
	queue<int>ai;
	ai.push(be-1);//这里直接记be下标,作为初始值
	int start;
	int next;
	while (!ai.empty())//队列空了说明都列举完了
	{
		start = ai.front();
		ai.pop();//出列
		next = bi[start].x + start;
		if (bi[next].y == -1)//-1说明楼层没有来过
		{
			if (next >= 0 && next < fl)
			{
				ai.push(next);
				bi[next].y = bi[start].y+1;//计数一定要放在里面
				//cout << next + 1 << ' ' << bi[next].y<<endl;
			}
		}
		next = start-bi[start].x;
		if (bi[next].y == -1)
		{
			if (next >= 0 && next < fl)
			{
				ai.push(next);
				bi[next].y = bi[start].y + 1;
				//cout << next + 1 <<' '<< bi[next].y << endl;
			}
		}
	}
}
int main()
{
	int i;
	while (cin >> fl)
	{
		if (fl == 0)
			break;
		cin >> be >> en;
		num = 0;
		for (i = 0; i < fl; i++)
		{
			cin >> bi[i].x;
			bi[i].y = -1;//默认都是-1及没有来过
		}
		bi[be - 1].y = 0;//初始值计为0;
		what();
		printf("%d\n", bi[en-1].y);
	}
		return 0;
}


  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值