(C语言)练习4——计算表达式

Problem Description

计算下列表达式值: 

Input

输入x和n的值,其中x为非负实数,n为正整数。

Output

输出f(x,n),保留2位小数。

Example Input

3 2

Example Output

2.00

利用C语言写的代码如下:

//利用了函数实现的
#include<stdio.h>
#include<math.h>
#include<stdlib.h>
double f(double x,int n);
int main()
{
	
	int n,x;
	scanf("%d %d",&x,&n);
	printf("式子=%.2f\n",f(x,n));
	return 0;
}

double f(double x,int n)  //输入n是次数,x是起始值
{
	double sum = 0;
	int i;
	for(i=1;i<=n;i++)
	{
		sum=sqrt(x+i);
		x=sum;
	}
	return sum;
}

 利用C++写的代码如下:

//#include <iostream>
//#include<math.h>
//#include<cstdio>
#include<bits/stdc++.h>
using namespace std;
double f(double x,int n)
{
    double sum=0;
    for(int i=1;i<=n;i++)
    {
        sum=sqrt(x+i);
        x=sum;
    }
    return sum;
}
int main()
{
      double x;
      int n;
      cin>>x>>n;
      printf("%.2lf\n",f(x,n));
    return 0;
}

 

参照大佬的:https://blog.csdn.net/Lycodeboy/article/details/53046144

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值