数据结构实验之栈六:下一较大值(二)
Time Limit: 150MS Memory limit: 8000K
题目描述
对于包含n(1<=n<=100000)个整数的序列,对于序列中的每一元素,在序列中查找其位置之后第一个大于它的值,如果找到,输出所找到的值,否则,输出-1。
输入
输入有多组,第一行输入t(1<=t<=10),表示输入的组数;
以后是 t 组输入:每组先输入n,表示本组序列的元素个数,之后依次输入本组的n个元素。
输出
输出有多组,每组之间输出一个空行(最后一组之后没有);
每组输出按照本序列元素的顺序,依次逐行输出当前元素及其查找结果,两者之间以-->间隔。
示例输入
2
4 12 20 15 18
5 20 15 25 30 6
示例输出
12-->20
20-->-1
15-->18
18-->-1
20-->25
15-->25
25-->30
30-->-1
6-->-1
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define stackmax 10000
#define stacknum 10000
struct node
{
int data;
int next;//存储data的下一较大值
int id; //存储data的下标以便按顺序输出
} a[100010], b;
typedef struct
{
struct node *base;
struct node *top;
int stacksize;
} SqStack;
int InitStack(SqStack &s)
{
s.base = (struct node*) malloc (stackmax*sizeof(struct node));
if (! s.base)
exit(0);
s.top = s.base;
s.stacksize = stackmax;
return 0;
}
int Push(SqStack &s , struct node e)
{
if(s.top-s.base >= s.stacksize)
{
s.base = (struct node *)realloc(s.base,(s.stacksize+stacknum)*sizeof(struct node));
if (! s.base ) exit(0);
s.top = s.base + s.stacksize;
s.stacksize += stacknum;
}
*s.top++=e;
}
int StackEmpty(SqStack &s)
{
if(s.top == s.base)
return 1;
else
return 0;
}
int Pop(SqStack &s)
{
if(s.top == s.base) return 0;
s.top--;
return 1;
}
void GetTop(SqStack &s, node &e)
{
e=*(s.top-1);
}
int large(SqStack &s, struct node a[], int n)
{
int i;
int *p, *q;
for(i=0; i<n; i++)
{
if(StackEmpty(s))
Push(s, a[i]);
else
{
while(!StackEmpty(s))
{
node e;
GetTop(s, e);
if(a[i].data>e.data)
{
int k = e.id;
a[k].next=a[i].data;
Pop(s);
}
else
break;
}
Push(s, a[i]);
}
}
for(i=0;i<n;i++)
printf("%d-->%d\n",a[i].data,a[i].next);
}
int main()
{
int t, n, i;
while(~scanf("%d", &t))
{
while(t--)
{
SqStack s;
InitStack(s);
scanf("%d", &n);
for(i=0; i<n; i++)
{
scanf("%d", &a[i].data);
a[i].id=i;
a[i].next=-1;
}
large(s, a, n);
if(t!=0) printf("\n");
}
}
}