数据结构实验之查找三:树的种类统计

数据结构实验之查找三:树的种类统计

Time Limit: 400MS Memory limit: 65536K

题目描述

随着卫星成像技术的应用,自然资源研究机构可以识别每一个棵树的种类。请编写程序帮助研究人员统计每种树的数量,计算每种树占总数的百分比。

输入

输入一组测试数据。数据的第1行给出一个正整数N (n <= 100000),N表示树的数量;随后N行,每行给出卫星观测到的一棵树的种类名称,树的名称是一个不超过20个字符的字符串,字符串由英文字母和空格组成,不区分大小写。

输出

按字典序输出各种树的种类名称和它占的百分比,中间以空格间隔,小数点后保留两位小数。

示例输入

2
This is an Appletree
this is an appletree

示例输出

this is an appletree 100.00%


ps:将每一种树当作一个二叉树的结点,树的种类名称用字符串数组存储,建立二叉顺序树, 字典序即中序遍历。


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <ctype.h>
using namespace std;
typedef int status;
typedef struct bitnode
{
    char data[25];//存储字符串
    int sum; //用以统计每种树出现的次数
    struct bitnode *lchild, *rchild;
}*bitree;
int n;
char s[25];
bitree Insert(bitree &t)
{
    if(!t)
    {
        t = new bitnode;
        t->lchild = NULL;
        t->rchild = NULL;
        t->sum = 1;
        strcpy(t->data, s);
    }
    else
    {
        if(strcmp(t->data, s)==0)//若树的种类相同,sum++;
           t->sum++;
        else if(strcmp(s,t->data)<0)
           t->lchild = Insert(t->lchild);
        else
           t->rchild = Insert(t->rchild);
    }
    return t;
}

void inorder(bitree &t)
{
    if(t)
    {
        inorder(t->lchild);
        printf("%s %.2lf%%\n", t->data, (1.0*t->sum/n)*100);
        inorder(t->rchild);
    }
}

int main()
{
    int i;
    scanf("%d", &n);
    bitree t;
    t = NULL;
    int j;
    getchar();
    for(j=0; j<n; j++)
    {

        gets(s);
        int l = strlen(s);
        for(i=0;i<l;i++)
       {
            s[i] = tolower(s[i]);//将大写字母转化为小写字母的函数包含在#include <ctype.h>头文件里
       }
        Insert(t);

    }
    inorder(t);
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值