数据结构实验之链表八:Farey序列

数据结构实验之链表八:Farey序列

Time Limit: 10MS  Memory Limit: 600KB
Problem Description

Farey序列是一个这样的序列:其第一级序列定义为(0/1,1/1),这一序列扩展到第二级形成序列(0/1,1/2,1/1),扩展到第三极形成序列(0/1,1/3,1/2,2/3,1/1),扩展到第四级则形成序列(0/1,1/4,1/3,1/2,2/3,3/4,1/1)。以后在每一级n,如果上一级的任何两个相邻分数a/c与b/d满足(c+d)<=n,就将一个新的分数(a+b)/(c+d)插入在两个分数之间。对于给定的n值,依次输出其第n级序列所包含的每一个分数。

Input
输入一个整数n(0<n<=100)
Output
依次输出第n级序列所包含的每一个分数,每行输出10个分数,同一行的两个相邻分数间隔一个制表符的距离。
Example Input
6
Example Output
0/1   1/6   1/5   1/4   1/3   2/5   1/2   3/5   2/3   3/4
4/5   5/6   1/1


#include <stdio.h>
#include <stdlib.h>
typedef int elemtype;
typedef int status;
typedef struct node
{
    elemtype data1, data2;
    node *next;
} node, *linklist;

linklist create(linklist head, int n)
{
    linklist tail1, tail2;
    head = (node *)malloc(sizeof(node));
    head->next = NULL;
    tail1 = (node *)malloc(sizeof(node));
    tail2 = (node *)malloc(sizeof(node));
    tail1->data1 = 0;
    tail1->data2 = 1;
    tail2->data1 = 1;
    tail2->data2 = 1;
    head->next = tail1;
    tail1->next = tail2;
    tail2->next = NULL;
    linklist p, q, s;
    for(int i=2; i<=n; i++)
    {
        p = head->next;
        while(p->next!=NULL)
        {
            q = p->next;
            if(p->data2+q->data2<=i)
            {
                s = (node *)malloc(sizeof(node));
                s->data1 = p->data1 + q->data1;
                s->data2 = p->data2 + q->data2;
                p->next = s;
                s->next = q;

            }
            p = p->next;
        }
    }

    return head;
}

void display(linklist head)
{
    linklist p;
    p = head->next;
    int count = 0;
    while(p)
    {
        count++;
        if(count%10==0)
            printf("%d/%d\n", p->data1, p->data2);
        else
            printf("%d/%d\t", p->data1, p->data2);
        p = p->next;
    }

}

int main()
{
    int n;
    scanf("%d", &n);
    linklist head;
    head = create(head, n);
    display(head);
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值