POJ 3150 Cellular Automaton

Cellular Automaton
Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 2975 Accepted: 1191
Case Time Limit: 2000MS

Description

cellular automaton is a collection of cells on a grid of specified shape that evolves through a number of discrete time steps according to a set of rules that describe the new state of a cell based on the states of neighboring cells. Theorder of the cellular automaton is the number of cells it contains. Cells of the automaton of order n are numbered from 1 to n.

The order of the cell is the number of different values it may contain. Usually, values of a cell of order m are considered to be integer numbers from 0 to m − 1.

One of the most fundamental properties of a cellular automaton is the type of grid on which it is computed. In this problem we examine the special kind of cellular automaton — circular cellular automaton of order n with cells of orderm. We will denote such kind of cellular automaton as n,m-automaton.

A distance between cells i and j in n,m-automaton is defined as min(|i − j|, n − |i − j|). A d-environment of a cell is the set of cells at a distance not greater than d.

On each d-step values of all cells are simultaneously replaced by new values. The new value of cell i after d-step is computed as a sum of values of cells belonging to the d-enviroment of the cell i modulo m.

The following picture shows 1-step of the 5,3-automaton.

The problem is to calculate the state of the n,m-automaton after k d-steps.

Input

The first line of the input file contains four integer numbers nmd, and k (1 ≤ n ≤ 500, 1 ≤ m ≤ 1 000 000, 0 ≤ d < n2 , 1 ≤ k ≤ 10 000 000). The second line contains n integer numbers from 0 to m − 1 — initial values of the automaton’s cells.

Output

Output the values of the n,m-automaton’s cells after k d-steps.

Sample Input

sample input #1
5 3 1 1
1 2 2 1 2

sample input #2
5 3 1 10
1 2 2 1 2

Sample Output

sample output #1
2 2 2 2 1

sample output #2
2 0 0 2 2

Source


   矩阵的快速幂+循环矩阵性质
  循环矩阵遵循代数运算法则。对于两个循环矩阵 AB 来说, A + B 也是循环矩阵。 AB 也是循环矩阵,并且 AB=BA。
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#define N 510
using namespace std;
__int64 a[N][N],b[N],temp[N][N];
int n,m,d,k;
int main()
{
    //freopen("data.txt","r",stdin);
    void f();
    while(scanf("%d",&n)!=EOF)
    {
        scanf("%d %d %d",&m,&d,&k);
        for(int i=0;i<=n-1;i++)
        {
            scanf("%I64d",&b[i]);
        }
        memset(a,0,sizeof(a));
        for(int i=0;i<=n-1;i++)
        {
            for(int j=0;j<=d;j++)
            {
                int x = (i+j)%n;
                a[i][x] = 1;
                x = ((i-j)%n+n)%n;
                a[i][x] = true;
            }
        }
        f();
        for(int i=0;i<=n-1;i++)
        {
            if(i==0)
            {
                printf("%I64d",b[i]);
            }else
            {
                printf(" %I64d",b[i]);
            }
        }
        printf("\n");
    }
    return 0;
}
void ba()
{
    for(int i=0;i<=n-1;i++)
    {
        __int64 sum = 0;
        for(int j=0;j<=n-1;j++)
        {
            sum=(sum+(b[j]*a[j][i])%m)%m;
        }
        temp[0][i] = sum;
    }
    for(int i=0;i<=n-1;i++)
    {
        b[i] = temp[0][i];
    }
}
void aa()
{
   for(int row=0;row<=0;row++)
   {
       for(int col=0;col<=n-1;col++)
       {
           __int64 sum = 0;
           for(int i=0;i<=n-1;i++)
           {
               sum=(sum+(a[row][i]*a[i][col])%m)%m;
           }
           temp[row][col] = sum;
       }
   }
   for(int i=0;i<=n-1;i++)
   {
       a[0][i] = temp[0][i];
   }
   int pian = 1;
   for(int i=1;i<=n-1;i++)
   {
       for(int j=0;j<=n-1;j++)
       {
           int pos = (pian+j)%n;
           a[i][pos] = a[0][j];
       }
       pian++;
   }
}
void f()
{
    while(k>1)
    {
        if(k&1)
        {
            ba();
        }
        aa();
        k=k>>1;
    }
    ba();
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值