UVA - 10340 All in All

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu

Submit Status

Description

Download as PDF

Problem E

All in All

Input: standard input

Output: standard output

Time Limit: 2 seconds

Memory Limit: 32 MB

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input Specification

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

Output Specification

For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

Source: ULM Local Contest

          
 
   
 
   
 
   
分析:
刘汝佳大白书里的水题。一开始居然把Yes和No写错了,结果错了几发,仔细看了一下,改了过来,就AC了。
uva又挂了,在poj1936交了一发(跟uva上的题一样,并且更详细,比如,规定:The length of s and t will no more than 100000.),ac了。
ac代码:(1)
#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=100005;
char s[maxn],t[maxn];
int main()
{
  while(scanf("%s%s",s,t)!=EOF)
  {
      int n=strlen(s),m=strlen(t);
      /*if(n>m)
      {
          printf("No\n");
          continue;
      }*/
      int i;
      int j=0;
      for(i=0;i<n;i++)
      {
          for(;j<m;j++)
          {
              if(s[i]==t[j])
              {
                  j++;break;
              }
          }
          if(j==m) break;
      }
      if(i==n||i==n-1&&s[n-1]==t[m-1]) printf("Yes\n");
      else printf("No\n");
  }
    return 0;
}
 
   
 
   
 
   
ac代码:(2)
#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=100005;
char s[maxn],t[maxn];
int main()
{
  while(scanf("%s%s",s,t)!=EOF)
  {
      int n=strlen(s),m=strlen(t);
      if(n>m)
      {
          printf("No\n");
          continue;
      }
      int i;
      int j=0;
      for(i=0;i<m;i++)
      {
         if(t[i]==s[j]&&j++==n-1)
         {
             break;
         }
      }
      if(j==n) printf("Yes\n");
      else printf("No\n");
  }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值