ZOJ Problem Set - 2829 Beautiful Number

Beautiful Number

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Mike is very lucky, as he has two beautiful numbers, 3 and 5. But he is so greedy that he wants infinite beautiful numbers. So he declares that any positive number which is dividable by 3 or 5 is beautiful number. Given you an integer N (1 <= N <= 100000), could you please tell mike the Nth beautiful number?

Input

The input consists of one or more test cases. For each test case, there is a single line containing an integer N.

Output

For each test case in the input, output the result on a line by itself.

Sample Input

1
2
3
4

Sample Output

3
5
6
9


Author:  MAO, Yiqiang

Source: Zhejiang University Local Contest 2007, Preliminary    




分析:

题意:

能被3或5整除的数叫做beautiful数。每次输入一个数n,要求输出第n个beautiful数的值。



水题。

打表即可。



ac代码:

#include <iostream>
#include<cstdio>
using namespace std;
const int maxn=300000+5;
int a[maxn];
void is_beautiful()//打表
{
    int i,j,k;
    int n=0;
    for(i=3;i<=300000;i++)
    {
        if(i%3==0||i%5==0)
        a[++n]=i;//小心数组越界
    }
}
int main()
{
    int n;
    is_beautiful();
    while(scanf("%d",&n)!=EOF)
    {
        printf("%d\n",a[n]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值