《ACM程序设计》书中题目U

Description
Mike is very lucky, as he has two beautiful numbers, 3 and 5. But he is so greedy that he wants infinite beautiful numbers. So he declares that any positive number which is dividable by 3 or 5 is beautiful number. Given you an integer N (1 <= N <= 100000), could you please tell mike the Nth beautiful number?

Input
The input consists of one or more test cases. For each test case, there is a single line containing an integer N.

Output
For each test case in the input, output the result on a line by itself.

Sample Input
1
2
3
4

Sample Output
3
5
6
9

是否能被3或5整除,做一下预处理,要不会超时,用map存下。

#include <bits/stdc++.h>
using namespace std;
int main()  
{  
    map<int, int> m;  
    int count=0,N,num=1;  
    while (1)  
    {  
        if (num%3==0||num%5==0)  
        {  
            count++;  
            m[count]=num;  
        }  
        num++;  
        if (count>100000)  
            break;  
    }  
    while (cin>>N)  
        cout<<m[N]<<endl;  
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值