ZOJ Problem Set - 2095 Divisor Summation

Divisor Summation

Time Limit: 5 Seconds       Memory Limit: 32768 KB

Give a natural number n (1 <= n <= 500000), please tell the summation of all its proper divisors.

Definition: A proper divisor of a natural number is the divisor that is strictly less than the number.

e.g. number 20 has 5 proper divisors: 1, 2, 4, 5, 10, and the divisor summation is: 1 + 2 + 4 + 5 + 10 = 22.


Input

An integer stating the number of test cases, and that many lines follow each containing one integer between 1 and 500000.


Output

One integer each line: the divisor summation of the integer given respectively.


Sample Input

3
2
10
20


Sample Output

1
8
22



Author:  Neal Zane
Source:  ZOJ Monthly, March 2004





分析:
题意:
定义:一个自然数的严格意义上的除数是比它本身小的除数。
给定一个自然数n(1<=n<=500000),要求输出它的所有严格意义上的除数的和。



先打表预处理所有500000以内的自然数的除数和,然后根据输入直接查询就行。这里的打表有一定技巧。


ac代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=500000+10;
int a[maxn];


void table()//打表,注意技巧
{
    int i,j;
    int m=sqrt(500000);
    //memset(a,1,sizeof(a));//memset置1出问题
    for(i=2;i<=500000;i++)
    a[i]=1;
    a[1]=0;
    for(i=2;i<=m;i++)//比如64的除数有1,2,4,8,16,32.则64=2*32=4*16=8*8,通过两重for循环可全部得到
    {
        a[i*i]+=i;//得到8
        for(j=i+1;j<=(500000/i);j++)
        {
            a[i*j]+=i+j;//分别得到2*32,4*16
        }
    }
}
int main()
{
    int t,n;
    table();
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        printf("%d\n",a[n]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值