ZOJ -2095 Divisor Summation

Divisor Summation

Time Limit: 5 SecondsMemory Limit: 32768 KB

Give a natural number n (1 <= n <= 500000), please tell the summation of all its proper divisors.
Definition: A proper divisor of a natural number is the divisor that is strictly less than the number.

e.g. number 20 has 5 proper divisors: 1, 2, 4, 5, 10, and the divisor summation is: 1 + 2 + 4 + 5 + 10 = 22.

Input
An integer stating the number of test cases, and that many lines follow each containing one integer between 1 and 500000.

Output
One integer each line: the divisor summation of the integer given respectively.

Sample Input
3
2
10
20

Sample Output
1
8
22

求n的因子和,先打表

#include<stdio.h>
#include<iostream>
using namespace std;

int f[500005];

int main()
{
    int t;
    int n;
    scanf("%d", &t);
    f[0]=f[1]=0;
    for(int i=1; i<=500001/2; i++)
    {
        for(int j=i*2; j<=500001; j+=i)//j只会取i的倍数
        {
            f[j]+=i;//在f[j]加i就是这个数的因子和
        }

    }


    while(t--)
    {
        scanf("%d",&n);
        printf("%d\n",f[n]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值