Time Limit: 1000MS | Memory Limit: 32768KB | 64bit IO Format: %lld & %llu |
Description
There is a strange clock, without any number written. Can you tell me what time it is now, based on the angle of the hour hand?
When the hour hand points right (0 degree), it is 3 o'clock. When it points to 80 degrees, it's between 0 o'clock and 1 o'clock. Note that there is no 12 o'clock. You should always write 0 o'clock instead.
Input
There are at most 10 test cases. Each case contains a single integer a (0 <= a < 360), the angle of the hour hand. The input ends with a = -1.
Output
For each test case, print the current time, in one of the following format:
- Exactly x o'clock - Between x o'clock and y o'clock
Note that, in the second format, x o'clock should be exactly one hour before y o'clock, So you cannot write something like "Between 3 o'clock and 2 o'clock".
Sample Input
90 245 -1
Sample Output
Exactly 0 o'clock Between 6 o'clock and 7 o'clock
Source
#include <iostream>
#include<cstdio>
using namespace std;
int main()
{
int a;
int x,y;
while(scanf("%d",&a)&&a!=-1)
{
if(a<90)
{
if(a%30==0)
{
x=3-a/30;
printf("Exactly %d o'clock\n",x);//用转义字符/'也不行
}
else
{
y=3-a/30;
x=y-1;
printf("Between %d o'clock and %d o'clock\n",x,y);
}
}
else if(a==90)
{
printf("Exactly 0 o'clock\n");
}
else
{
if(a%30==0)
{
x=12-(a-90)/30;
printf("Exactly %d o'clock\n",x);
}
else
{
x=12-(a-90)/30-1;
y=x+1;
printf("Between %d o'clock and %d o'clock\n",x,y);
}
}
}
return 0;
}
#include <stdio.h>
int main(void)
{
int a;
while (scanf("%d", &a) != EOF && a != -1)
{
if (a % 30 == 0)
printf("Exactly %d o'clock\n", (15 - a/30) % 12);
else
printf("Between %d o'clock and %d o'clock\n", (15 - a/30 - 1) % 12, (15 - a/30) % 12);
}
return 0;
}