zoj3191 Strange Clock(水题,但为何是wrong answer???)

Time Limit: 1000MS Memory Limit: 32768KB 64bit IO Format: %lld & %llu

 Status

Description

There is a strange clock, without any number written. Can you tell me what time it is now, based on the angle of the hour hand?

When the hour hand points right (0 degree), it is 3 o'clock. When it points to 80 degrees, it's between 0 o'clock and 1 o'clock. Note that there is no 12 o'clock. You should always write 0 o'clock instead.

Input

There are at most 10 test cases. Each case contains a single integer a (0 <= a < 360), the angle of the hour hand. The input ends with a = -1.

Output

For each test case, print the current time, in one of the following format:

- Exactly x o'clock
- Between x o'clock and y o'clock

Note that, in the second format, x o'clock should be exactly one hour before y o'clock, So you cannot write something like "Between 3 o'clock and 2 o'clock".

Sample Input

90
245
-1

Sample Output

Exactly 0 o'clock
Between 6 o'clock and 7 o'clock

Source

The 34th ACM-ICPC Asia Regional 2009 Ningbo Site NIT Cup National Invitation Contest
 
 
分析:
水题。我的代码:(查了好久,一直返回wrong answer)

#include <iostream>
#include<cstdio>
using namespace std;

int main()
{
    int a;
    int x,y;
    while(scanf("%d",&a)&&a!=-1)
    {
        if(a<90)
        {
            if(a%30==0)
            {
                x=3-a/30;
                printf("Exactly %d o'clock\n",x);//用转义字符/'也不行
            }
            else
            {
                y=3-a/30;
                x=y-1;
                printf("Between %d o'clock and %d o'clock\n",x,y);
            }
        }
        else if(a==90)
        {
            printf("Exactly 0 o'clock\n");
        }
        else
        {
            if(a%30==0)
            {
                x=12-(a-90)/30;
                printf("Exactly %d o'clock\n",x);
            }
            else
            {
                x=12-(a-90)/30-1;
                y=x+1;
                printf("Between %d o'clock and %d o'clock\n",x,y);
            }
        }
    }
    return 0;
}

 
ac代码:
#include <stdio.h>
int main(void)
{
    int a;
    
    while (scanf("%d", &a) != EOF && a != -1)
    {
        if (a % 30 == 0)
            printf("Exactly %d o'clock\n", (15 - a/30) % 12);
        else
            printf("Between %d o'clock and %d o'clock\n", (15 - a/30 - 1) % 12, (15 - a/30) % 12);
    }
    
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值