写一函数,将两个字符串连接

Description

写一函数,将两个字符串连接

Input

两行字符串

Output

链接后的字符串

Sample Input

123
abc

Sample Output

123abc
#include <iostream>
using namespace std;
int main()
{
	char s1[10],s2[10];
	int i=0,j=0;
	cin>>s1>>s2;
	while(s1[i]!='\0')
		i++;
	while(s2[j]!='\0')
		s1[i++]=s2[j++];
	    s1[i]='\0';
		cout<<s1<<endl;
		return 0;
}
另一种方法:
#include <iostream>
#include <cstring>
using namespace std;
int main()
{ 
	char s1[10],s2[10];
	cin>>s1>>s2;
    strcat(s1,s2);
    cout<<s1<<endl;
	return 0;
}
注意:1.定义字符串
      2.strcat函数头文件在C语言为<string.h>
                         在C++中为<cstring>
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值