zoj 2236 Wireless Network

Description
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. “O p” (1 <= p <= N), which means repairing computer p.
2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output
For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

Source
POJ Monthly,HQM
分析:相连接问题,很裸并查集类题。不过,我先前用一个2维数组表示坐标,和标记,结果 超内存。后面想了下,是犯傻了,直接用结构体表示就好。

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<algorithm>
using namespace std;
int b[1005];

struct node{
    int x,y;
    bool flag;
    node()
    {
        flag=false;
    }
}f[10005];

int findset(int v)    
{  
    while(v!=b[v])  
        v=b[v];  
     return v; 
} 

void union_nodes(int aa, int bb)     
{  
    int a1 = findset(aa);  
    int b1 = findset(bb);
    if(a1 != b1)    
    {
        b[a1] = b1;
    }
} 


int main()
{
    int n,d;
      scanf("%d %d",&n,&d);
        for(int i=1;i<=n;i++)
        {
            b[i]=i;
            int xi,yi;
            scanf("%d %d",&xi,&yi);
            f[i].x=xi,f[i].y=yi;
        }

        char ch;
    while(scanf("%c",&ch)!=EOF)
    {
        if(ch=='O')
        {
            int p;
            scanf("%d",&p);
            int k1=f[p].x,k2=f[p].y;
             f[p].flag=true;
             for(int i=1;i<=n;i++)
             {
                if(i==p)
                continue;

                if(f[i].flag)
                {
                    int v=(f[i].x-k1)*(f[i].x-k1);
                    int u=(f[i].y-k2)*(f[i].y-k2);
                    if(v+u<=d*d)
                    {
                          union_nodes(p,i);
                    }
                }
             }
        }

        else if(ch=='S')
        {
            int p,q;
            scanf("%d%d",&p,&q);
            if(findset(q)!=findset(p))
            printf("FAIL\n");
            else
            printf("SUCCESS\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值