并查集—A - Wireless Network

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. “O p” (1 <= p <= N), which means repairing computer p.
2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.
Output
For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS

#include<stdio.h>
#include<math.h>
#include<string.h>
struct opint
{
    int x, y;
} pp[1008];

int open[1008];
int link[1008];

int findlink(int x)
{
    if(link[x]==x)
        return x;
    return findlink(link[x]);
}

void join(int a,int b)//把可以通信的放在一个组。
{
    int lina=findlink(a);
    int linb=findlink(b);
    if(lina!=linb)
        link[lina]=linb;
}

int dis(opint a, opint b, int c)
{
    double dis = sqrt((a.x - b.x) * (a.x - b.x) + (a.y - b.y) * (a.y - b.y));
    if(dis <= c)//可以通信的返回真。
        return 1;
    else
        return 0;
}

int main(void)
{
    memset(link, 0, sizeof(link));
    memset(open, 0, sizeof(open));//open是一个存放维修后的电脑的数组。
    int i,j,n,d;
    char operation;
    int p,q;
    scanf("%d%d",&n,&d);
    for(i=1; i<=n; i++)
        link[i]=i;
    for (i = 1; i <= n; i++)
    {
        scanf("%d%d", &pp[i].x, &pp[i].y);
    }

    while(~scanf(" %c %d",&operation,&p))//%c前面要有一个空格。
    {
        if(operation == 'S')//遇到 S 的字符,即查看电脑是否可以通信。
        {
            scanf("%d", &q);//需要再输入一个电脑。
            if(findlink(link[p]) == findlink(link[q]))//指p,q电脑属于一组。
                printf("SUCCESS\n");
            else
                printf("FAIL\n");
        }
        else
        {
            open[p]=1;
            for(j=1; j<=n; j++)
            {
                if(p!=j&&open[j])//遍历除了刚输入的修后的电脑外,其他修好的电脑。
                    if(dis(pp[p],pp[j],d))//在最大距离范围内都可以放一组。
                        join(p,j);
            }
        }
    }
    return 0;
}

思路:我们需要查询已经修好的电脑有哪些,在修好的这些电脑里面,那些的距离是在最大范围内的,因为只有已经修好并且在最大范围内的电脑才可以通信。首先把可以通信的电脑放在一个组里,在最后查询时,只要在同一个组里就说明可以通信。

想哭,在找bug的时候真的是最痛苦的时候,所以在写代码的时候一定要小心小心再小心。一个空格就可能让你崩溃。这个bug真的是,先一个函数一个函数的找,问题出在主函数中,又一行一行的找,原来是一个“空格”在作怪。

while(~scanf(” %c %d”,&operation,&p))

在%c的前面有一个空格。注意注意!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值