hdu 1042 N!(大数阶乘)

7 篇文章 0 订阅

链接:hdu 1042

Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 6
 
模拟算数乘法,将每一位与乘数相乘,记录进位。

AC代码:
#include<stdio.h>
#include<string.h>
int s[10010];
int main()
{
    int i,j,n,m,c;
    while(scanf("%d",&n)!=EOF){
        memset(s,0,sizeof(s));
        s[0]=1;
        c=0;
        for(i=2;i<=n;i++)
            for(j=0;j<=10000;j++){
                m=s[j]*i+c;
                s[j]=m%10000;       //如果用char 处理,m只需对10取余或除以10
                c=m/10000;
        }
        for(i=10000;i>=0;i--)        //处理前导0
            if(s[i]!=0)
                break;
        printf("%d",s[i]);         //不能有前导0
        for(i--;i>=0;i--)
            printf("%04d",s[i]);      //中间的0不能省略
        printf("\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值