poj 1328 Radar Installation (贪心)

链接:poj 1328

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

题意:X轴表示海岸线,在X轴上方是海 ,下方是陆地 ,海上有n个小岛,现在要在海岸线上安装雷达,

           雷达的覆盖范围是一个以雷达为圆心,以d为半径的圆,请用最少的雷达覆盖所有的小岛;

            当无法覆盖时输出-1

思路:算出 每个小岛能被覆盖的雷达的圆心范围,即以小岛为圆心 d为半径 作圆,该圆与X轴的交点:

           左交点为x-sqrt(d*d-y*y); 

           右交点为x+sqrt(d*d-y*y);

           按照 左交点 从小到大排序,第一个雷达放在第一个点的右交点,

           如果某点的左交点在当前雷达的右边,则需安装一个新雷达,更新雷达的位置

           否则 如果 某点的右交点也在当前雷达的左边,则把当前雷达的圆心更新为该点的右交点;


贪心思想,开始wrong了好多遍,同样的思路,网上解题报告代码一遍就AC,始终想不明白,突然发现 记录雷达的坐标定义成了 int型,改了就A了,以后得细心、、、大哭


AC代码:

#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
struct stu
{
    double x,y,l,r;
};
int cmp(struct stu a,struct stu b)
{
    return a.l<b.l;
}
int main()
{
    int i,j,n,d,m,t;
    double k;
    struct stu s[1005];
    for(i=1;;i++){
        scanf("%d%d",&n,&d);
        t=1;
        if(n==0&&d==0)
            break;
        for(j=0;j<n;j++){
            scanf("%lf%lf",&s[j].x,&s[j].y);
            s[j].l=s[j].x-sqrt(d*d-s[j].y*s[j].y);
            s[j].r=s[j].x+sqrt(d*d-s[j].y*s[j].y);
            if(s[j].y>d||d<=0)
                t=0;
        }
        if(t==0){
            printf("Case %d: -1\n",i);
            continue;
        }
        sort(s,s+n,cmp);
        k=s[0].r;
        m=1;
        for(j=1;j<n;j++){
            if(s[j].l>k){
                m++;
                k=s[j].r;
            }
            else if(s[j].r<k)
                k=s[j].r;
        }
        printf("Case %d: %d\n",i,m);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值