hdu 1789 Doing Homework again(贪心)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10716    Accepted Submission(s): 6308


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
题意:有n份作业,完成一份作业需要一天,每份作业有个最迟提交期限和一个不提交会被扣的分数,问你最少会被扣几分?

思路:这道题有点难度,贪心也不是一眼能看出来。 把分数从大到小排序是错的,分数/天数排序也是错的。

此题贪心策略是:取当前最大的分数,然后使用可放入的最大的天数。比如有一个作业最迟完成是4天,价值是10,现在有第1,2,3,4四天可以选择,我们就选择用第四天去完成这份作业。因为在这道题里,截止日期越少越珍贵,我们应尽量使用截止日期长的。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
#define N 1010
int flag[N];
struct Point
{
    int day,v;
}work[N];
bool cmp(Point a,Point b)
{
        return a.v>b.v;
}
int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
                scanf("%d",&work[i].day);
        for(int i=0;i<n;i++)
                scanf("%d",&work[i].v);
        sort(work,work+n,cmp);
        int ans=0;
        memset(flag,0,sizeof(flag));
        for(int i=0;i<n;i++)
        {
            int is=0;
            for(int j=work[i].day;j>=1;j--)
                if(!flag[j])
            {
                flag[j]=1;
                is=1;
                break;
            }
            if(is==0)
                ans+=work[i].v;
        }
        printf("%d\n",ans);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值