XTU 1236 Fraction(小数化分数)

Fraction

Accepted : 149 Submit : 988
Time Limit : 1000 MS Memory Limit : 65536 KB

Fraction

Problem Description:

Everyone has silly periods, especially for RenShengGe. It's a sunny day, no one knows what happened to RenShengGe, RenShengGe says that he wants to change all decimal fractions between 0 and 1 to fraction. In addtion, he says decimal fractions are too complicate, and set that  is much more convient than 0.33333... as an example to support his theory.

So, RenShengGe lists a lot of numbers in textbooks and starts his great work. To his dissapoint, he soon realizes that the denominator of the fraction may be very big which kills the simplicity that support of his theory.

But RenShengGe is famous for his persistence, so he decided to sacrifice some accuracy of fractions. Ok, In his new solution, he confines the denominator in [1,1000] and figure out the least absolute different fractions with the decimal fraction under his restriction. If several fractions satifies the restriction, he chooses the smallest one with simplest formation.

Input

The first line contains a number T(no more than 10000) which represents the number of test cases.

And there followed T lines, each line contains a finite decimal fraction x that satisfies .

Output

For each test case, transform x in RenShengGe's rule.

Sample Input

3
0.9999999999999
0.3333333333333
0.2222222222222

Sample Output

1/1
1/3
2/9

题意:给你一个小数,化成分数输出,分数要是最简形式(gcd)

思路:枚举分母,注意这里如果去枚举分子就会TLE。 这里有一个性质,分子=分母*结果的四舍五入值

即9/10=0.9 9≈10*0.9  1/9=0.111111111 1≈9*0.1111111111

代码:

#include <iostream>
#include <math.h>
#include<string.h>
#include<algorithm>
#include<stdio.h>
using namespace std;
const double eps = 1e-8;
int gcd(int a,int b){
    return b==0?a:gcd(b,a%b);
}
int main()
{
    int tcase;
    int a,b;
    scanf("%d",&tcase);
    while(tcase--){
        double c;
        scanf("%lf",&c);
        double MIN = 999999;
        for(int i=1;i<=1000;i++){
            int j = (int)(i*c+0.5);
            if(j<=i){
                double d=j*1.0/i;  ///当前答案
                double e = fabs(c-d);
                if(MIN>e){
                    a = i;
                    b = j;
                    MIN = e;
                }
                if(MIN<eps) break;
            }
            if(MIN<eps) break;
        }
        int t = gcd(a,b);
        a = a/t,b = b/t;
        printf("%d/%d\n",b,a);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值