hdu 4993 Revenge of ex-Euclid(水题)

Revenge of ex-Euclid

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 686    Accepted Submission(s): 404


Problem Description
In arithmetic and computer programming, the extended Euclidean algorithm is an extension to the Euclidean algorithm, which computes, besides the greatest common divisor of integers a and b, the coefficients of Bézout's identity, that is integers x and y such that ax + by = gcd(a, b).
---Wikipedia

Today, ex-Euclid takes revenge on you. You need to calculate how many distinct positive pairs of (x, y) such as ax + by = c for given a, b and c.
 

Input
The first line contains a single integer T, indicating the number of test cases. 

Each test case only contains three integers a, b and c.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= a, b, c <= 1 000 000
 

Output
For each test case, output the number of valid pairs.
 

Sample Input
  
  
2 1 2 3 1 1 4
 

Sample Output
  
  
1 3
 

题意:求ax+by=c,abxy都是正整数,问一共有几组解(x,y)

思路:被题目误导了,在扩展欧几里得上改了很久一直WA。  后来发现是个水题。。直接枚举x就好了,最多枚举1000000一开始还以为过不了。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define LL long long

int main()
{
    LL T,x,y;
    LL a,b,c;
    scanf("%lld",&T);
    while(T--)
    {
        scanf("%lld %lld %lld",&a,&b,&c);
        LL ans=0;
        for(LL i=1;;i++)
        {
            if((c-a*i)/b<=0) break;
            if((c-a*i)%b!=0) continue;
            ans++;
        }
        printf("%lld\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值