hdu 5066 Harry And Physical Teacher(物理)

Harry And Physical Teacher

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 628    Accepted Submission(s): 339


Problem Description
As we all know, Harry Porter learns magic at Hogwarts School. However, learning magical knowledge alone is insufficient to become a great magician. Sometimes, Harry also has to gain knowledge from other certain subjects, such as language, mathematics, English, and even algorithm. 
Today, Harry's physical teacher set him a difficult problem: if a small ball moving with a speed  V0  made a completely elastic collision with a car moving towards the same direction with a speed  V(V<V0) , and the car far outweighs the ball, what was the speed of the small ball after the collision?
This problem was so difficult that Harry hasn't figure out how to solve it. Therefore, he asks you for help. Could you do him this favor?
 

Input
They are several test cases, you should process to the end of file.
There are two integers  V  and  V0  for each test case. All the integers are 32-bit signed non-negative integers.
 

Output
For each test case, just output one line that contains an integer indicate the speed of the small ball after the collision.
 

Sample Input
  
  
0 10
 

Sample Output
  
  
-10
题意:一个速度为v0的小球和一个速度为v的汽车在同一个方向上运动,小球在车后面,车的质量远远大于小球,两者之间碰撞时完全弹性碰撞,问小球撞完后的速度是多少

思路:联立动能定理和动量守恒定理可以得到v=2*v1-v0

代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;

int main()
{
    long long n,m;
    while(~scanf("%lld %lld",&n,&m))
    {
        if(n>m) swap(n,m);
        printf("%lld\n",2*n-m);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值