GTY's math problem
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 2098 Accepted Submission(s): 773
Problem Description
GTY is a GodBull who will get an Au in NOI . To have more time to learn algorithm knowledge, he never does his math homework. His math teacher is very unhappy for that, but she can't do anything because GTY can always get a good mark in math exams. One day, the math teacher asked GTY to answer a question. There are four numbers on the blackboard -
a,b,c,d
. The math teacher wants GTY to compare
ab
with
cd
. Because GTY never does his homework, he can't figure out this problem! If GTY can't answer this question correctly, he will have to do his homework. So help him!
Input
Multi test cases (about 5000). Every case contains four integers a,b,c,d(
1≤a,b,c,d≤1000
)separated by spaces. Please process to the end of file.
Output
For each case , if
ab>cd
, print '>'. if
ab<cd
, print '<'. if
ab=cd
, print '='.
Sample Input
2 1 1 2 2 4 4 2 10 10 9 11
Sample Output
> = <
思路:没有给mod无法直接求得a的b次方答案,但是这里不要我们求的结果,所以我们只要有大小关系就好了。
所以我们考虑对a的b次方取个对数(不会影响大小)
然后我们去比b*log(a)和d*log(c)的大小即可
注意精度问题,要用eps
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 1050
#define eps 1e-8
int main()
{
double a,b,c,d;
while(~scanf("%lf %lf %lf %lf",&a,&b,&c,&d))
{
double bb=b*log(a);
double cc=d*log(c);
if(fabs(bb-cc)<eps) printf("=\n");
else if(bb-cc<eps) printf("<\n");
else printf(">\n");
} return 0;
}