hdu 5174 Ferries Wheel(模拟)

Ferries Wheel

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1650    Accepted Submission(s): 493


Problem Description
The Ferries Wheel is a circle,rounded by many cable cars,and the cars are numbered  1,2,3...K1,K  in order.Every cable car has a unique value and  A[i1]<A[i]<A[i+1](1<i<K) .


Today,Misaki invites  N  friends to play in the Ferries Wheel.Every one will enter a cable car. One person will receive a kiss from Misaki,if this person satisfies the following condition: (his/her cable car's value + the left car's value
% INT_MAX = the right car's value,the  1st  car’s left car is the  kth  car,and the right one is  2nd  car,the  kth  car’s left car is the  (k1)th  car,and the right one is the  1st  car.

Please help Misaki to calculate how many kisses she will pay,you can assume that there is no empty cable car when all friends enter their cable cars,and one car has more than one friends is valid.
 

Input
There are many test cases.
For each case,the first line is a integer  N(1<=N<=100)  means Misaki has invited  N  friends,and the second line contains  N  integers  val1,val2,...valN , the  val[i]  means the  ith  friend's cable car's value.
(0<=val[i]<=  INT_MAX).

The INT_MAX is  2147483647 .
 

Output
For each test case, first output Case #X: ,then output the answer, if there are only one cable car, print "-1";
 

Sample Input
  
  
3 1 2 3 5 1 2 3 5 7 6 2 3 1 2 7 5
 

Sample Output
  
  
Case #1: 1 Case #2: 2 Case #3: 3
Hint
In the third sample, the order of cable cars is {{1},{2}, {3}, {5}, {7}} after they enter cable car,but the 2nd cable car has 2 friends,so the answer is 3.
 
题意:有n个朋友,每个朋友可能在k个车厢里的任一个,每个车厢权值是递增的

现在问你,有多少给满足(本身权值+左边权值)%INF=右边权值

思路:因为车厢是递增的,排完序后去重,记下去重后每个权值的个数,表示这个车厢的人的个数,然后直接O(n)枚举一遍即可

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 150
#define mod 2147483647
long long a[N],num[N];
int main()
{
    int n,t=1;
    while(~scanf("%d",&n))
    {
        for(int i=1; i<=n; i++)
            scanf("%lld",&a[i]);
        sort(a+1,a+1+n);
        int cnt=1;
        num[1]=1;
        for(int i=2; i<=n; i++)
            if(a[i]!=a[i-1])
            {
                a[++cnt]=a[i];
                num[cnt]=1;
            }
            else num[cnt]++;
        long long ans=0;
        for(int i=1;i<=cnt;i++)
        {
            int l,r;
            if(i==1) l=cnt;
            else l=i-1;
            if(i==cnt) r=1;
            else r=i+1;
            if((a[i]+a[l])%mod==a[r]) ans+=num[i];
        }
        if(cnt==1) printf("Case #%d: -1\n",t++);
        else printf("Case #%d: %lld\n",t++,ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值