hdu 5182 PM2.5(排序)

PM2.5

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1215    Accepted Submission(s): 605


Problem Description
Nowadays we use content of PM2.5 to discribe the quality of air. The lower content of PM2.5 one city have, the better quality of air it have. So we sort the cities according to the content of PM2.5 in asending order.

Sometimes one city’s rank may raise, however the content of PM2.5 of this city may raise too. It means that the quality of this city is not promoted. So this way of sort is not rational. In order to make it reasonable, we come up with a new way to sort the cityes. We order this cities through the diffrence between twice measurement of content of PM2.5 (first measurement – second measurement) in descending order, if there are ties, order them by the second measurement in asending order , if also tie, order them according to the input order.
 

Input
Multi test cases (about  100 ), every case contains an integer  n  which represents there are  n  cities to be sorted in the first line.
Cities are numbered through 0 to  n1 .
In the next  n  lines each line contains two integers which represent the first and second measurement of content of PM2.5
The ith line describes the information of city  i1
Please process to the end of file.

[Technical Specification]
all integers are in the range  [1,100]
 

Output
For each case, output the cities’ id in one line according to their order.
 

Sample Input
  
  
2 100 1 1 2 3 100 50 3 4 1 2
 

Sample Output
  
  
0 1 0 2 1

题意:每一个城市有两个权值,先按照第一权值-第二权值降序排序,如果第一权值-第二权值相等,再按照第二权值排序,否则按照输入的顺序排序

思路:直接sort即可,三级排序。具体看代码吧

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
struct Node
{
    int v,w;
    int id;
} a[10000];
bool cmp(Node a,Node b)
{
    if(a.v==b.v&&a.w==b.w) return a.id<b.id;
    if(a.v==b.v) return a.w<b.w;
    return a.v>b.v;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0; i<n; i++)
        {
            scanf("%d %d",&a[i].v,&a[i].w);
            a[i].v-=a[i].w;
            a[i].id=i;
        }
        sort(a,a+n,cmp);
        for(int i=0; i<n-1; i++)
            printf("%d ",a[i].id);
        printf("%d\n",a[n-1].id);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值