hdu-6198number number number

Problem Description
We define a sequence F:

⋅ F0=0,F1=1;
⋅ Fn=Fn−1+Fn−2 (n≥2).

Give you an integer k, if a positive number n can be expressed by
n=Fa1+Fa2+…+Fak where 0≤a1≤a2≤⋯≤ak, this positive number is mjf−good. Otherwise, this positive number is mjf−bad.
Now, give you an integer k, you task is to find the minimal positive mjf−bad number.
The answer may be too large. Please print the answer modulo 998244353.

Input
There are about 500 test cases, end up with EOF.
Each test case includes an integer k which is described above. (1≤k≤109)

Output
For each case, output the minimal mjf−bad number mod 998244353.

Sample Input
1

Sample Output
4
先写出几项找到规律是求第i个mjf−bad number就是第2*i+3项斐波那契数列的值。
矩阵快速幂模版题。之前一直没做矩阵快速幂的题,还好队友写出来了。

#include <iostream>
#include <cstdio>
#include <cstring>
#define LL long long
#define MOD 998244353

using namespace std;

struct matrix
{
    LL x[3][3];
};

struct matrix mutimatrix(struct matrix a,struct matrix b)
{
    struct matrix temp;
    memset(temp.x,0,sizeof(temp.x));
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<2;j++)
        {
            for(int k=0;k<2;k++)
            {
                temp.x[i][j]=temp.x[i][j]+a.x[i][k]*b.x[k][j];
                temp.x[i][j]=temp.x[i][j]%MOD;
            }
        }
    }
    return temp;
}

struct matrix pow_matrix(struct matrix a,LL b)
{
    struct matrix temp;
    memset(temp.x,0,sizeof(temp.x));
    for(int i=0;i<2;i++)
    {
        temp.x[i][i]=1;
    }
    while(b)
    {
        if(b&1)
        {
            temp=mutimatrix(temp,a);
        }
        a=mutimatrix(a,a);
        b>>=1;
    }
    return temp;
}

int main()
{
    LL n;
    while(scanf("%lld",&n)!=EOF)
    {
        struct matrix temp,ans;
        temp.x[0][0]=1;
        temp.x[0][1]=1;
        temp.x[1][0]=1;
        temp.x[1][1]=0;
        ans=pow_matrix(temp,2*n+3);
        printf("%lld\n",ans.x[0][1]-1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值