hdu5505(好题)

GT and numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 174    Accepted Submission(s): 53



Problem Description
You are given two numbers N and M .

Every step you can get a new N in the way that multiply N by a factor of N .

Work out how many steps can N be equal to M at least.

If N can't be to M forever,print 1 .
 

Input
In the first line there is a number T . T is the test number.

In the next T lines there are two numbers N and M .

T1000 , 1N1000000 , 1M263 .

Be careful to the range of M.

You'd better print the enter in the last line when you hack others.

You'd better not print space in the last of each line when you hack others.
 

Output
For each test case,output an answer.
 

Sample Input
  
  
3 1 1 1 2 2 4
 

Sample Output
  
  
0 -1 1
 

Source
BestCoder Round #60

如果AA大于BB那么显然无解。

考虑把AABB分解质因数。

BB存在AA没有的质因数也显然无解。

对于某一个AA的质因数的次数。为了加速接近BB,它一定是每次翻倍,最后一次的时候把剩下的加上。

那么答案就是最小的kk使得2^{k}*A_{num} \geq B_{num}2kAnumBnum

最后把每个质因数的答案max起来即可。

BB可以刚好等于2^{63}263,这样就要开unsigned long long。

#include <map>
#include <set>
#include <stack>
#include <queue>
#include <cmath>
#include <ctime>
#include <vector>
#include <cstdio>
#include <cctype>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
typedef unsigned long long ll;
#define INF 0x3f3f3f3f
#define inf -0x3f3f3f3f
#define lson k<<1, L, mid
#define rson k<<1|1, mid+1, R
#define mem0(a) memset(a,0,sizeof(a))
#define mem1(a) memset(a,-1,sizeof(a))
#define mem(a, b) memset(a, b, sizeof(a))
int cnt;
int prime[1110000];
ll is_prime[111000];

void isa_prime(){                            //删选素数
    mem0(prime);
    mem0(is_prime);
    cnt=0;
    for(int i=2;i<=1000100;i++){
        if(prime[i]==0){
            is_prime[cnt]=i;
            cnt++;
            for(int j=i+i;j<=1000100;j+=i)
                prime[j]=1;
        }
    }
}

int getp(ll x,ll y){
    int ans=0;
    while(x%y==0&&x>0){
        ans++;
        x/=y;
    }
    return ans;
}

void solve(ll n,ll m){
    int ans=1;
    int flag=0;
    for(int i=0;i<cnt&&is_prime[i]<=n;i++){
        if(n%is_prime[i]==0||m%is_prime[i]==0){
            int x=getp(n,is_prime[i]);
            int y=getp(m,is_prime[i]);
            if(x==0&&y!=0){
                printf("-1\n");
                flag=1;
                break;
            }
            int cnt1=0;
            while(y>x){
                x*=2;
                cnt1++;
            }
            ans=max(cnt1,ans);
            while(n%is_prime[i]==0&&n>0)
                n/=is_prime[i];
            while(m%is_prime[i]==0&&m>0)//这里要注意
                m/=is_prime[i];
        }
    }
    if(flag==0&&m==1)
        printf("%d\n",ans);
    else if(flag==0)
        printf("-1\n");
}

int main(){
    ll n,m;
    int t;
    isa_prime();
    scanf("%d",&t);
    for(int case1=1;case1<=t;case1++){
        scanf("%I64u%I64u",&n,&m);
        if(m%n!=0){
            printf("-1\n");
            continue;
        }
        else if(n==1){
            if(m==1)
                printf("0\n");
            else
                printf("-1\n");
        }
        else if(n==m)
            printf("0\n");
        else{
            solve(n,m);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值