POJ 3744

Scout YYF I
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4055 Accepted: 1042

Description

YYF is a couragous scout. Now he is on a dangerous mission which is to penetrate into the enemy's base. After overcoming a series difficulties, YYF is now at the start of enemy's famous "mine road". This is a very long road, on which there are numbers of mines. At first, YYF is at step one. For each step after that, YYF will walk one step with a probability of p, or jump two step with a probality of 1- p. Here is the task, given the place of each mine, please calculate the probality that YYF can go through the "mine road" safely.

Input

The input contains many test cases ended with  EOF.
Each test case contains two lines.
The First line of each test case is  N (1 ≤  N ≤ 10) and  p (0.25 ≤  p ≤ 0.75) seperated by a single blank, standing for the number of mines and the probability to walk one step.
The Second line of each test case is N integer standing for the place of N mines. Each integer is in the range of [1, 100000000].

Output

For each test case, output the probabilty in a single line with the precision to 7 digits after the decimal point.

Sample Input

1 0.5
2
2 0.5
2 4

Sample Output

0.5000000
0.2500000

Source

我的第一道矩阵快速幂,原来以为这个很高端,现在看来也就是那么几十行代码。

这题如果数据小点儿可以递推过:

Ans[i]=p*Ans[i-1]+(1-p)*Ans[i-2]

矩阵快速幂的话:


#include <cstdio>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <map>
#include <string>
#include <stack>
#include <cctype>
#include <vector>
#include <queue>
#include <set>
#include <utility>
#include <cassert>
using namespace std;
///#define Online_Judge
#define outstars cout << "***********************" << endl;
#define clr(a,b) memset(a,b,sizeof(a))
#define lson l , m  , rt << 1
#define rson m + 1 , r , rt << 1 | 1
#define mk make_pair
#define FOR(i , x , n) for(int i = (x) ; i < (n) ; i++)
#define FORR(i , x , n) for(int i = (x) ; i <= (n) ; i++)
#define REP(i , x , n) for(int i = (x) ; i > (n) ; i--)
#define REPP(i ,x , n) for(int i = (x) ; i >= (n) ; i--)
const int MAXN = 1e8 + 500;
const int sigma_size = 26;
const long long LLMAX = 0x7fffffffffffffffLL;
const long long LLMIN = 0x8000000000000000LL;
const int INF = 0x7fffffff;
const int IMIN = 0x80000000;
#define eps 1e-8
const int MOD = (int)1e9 + 7;
typedef long long LL;
const double PI = acos(-1.0);
typedef double D;
typedef pair<int , int> pi;
///#pragma comment(linker, "/STACK:102400000,102400000")
int a[15];
D b[5][5] , s[5] , tmp[5][5] , temp[5] , p;
D Count(int t)
{
    b[0][0] = p;
    b[0][1] = 1 - p;
    b[1][0] = 1;
    b[1][1] = 0;
    s[0] = 1;
    s[1] = 0;
    while(t)
    {
        if(t& 1)
        {
            FOR(i , 0 , 2)
            {
                temp[i] = 0;
                FOR(j ,0 , 2)
                {
                    temp[i] += b[i][j] * s[j];
                }
            }
            FOR(i ,0 ,2)s[i] = temp[i];
        }
        t /= 2;
        FOR(i ,0 ,2)FOR(j ,0 , 2)
        {
            tmp[i][j] = 0;
            FOR(k , 0 ,2)tmp[i][j] += b[i][k] * b[k][j];
        }
        FOR(i ,0 , 2)FOR(j , 0 , 2)b[i][j] = tmp[i][j];
    }
    return s[0];
}
int main()
{
//    freopen("out.text" , "w" , stdout);
    int n;
    D ans;
    while(~scanf("%d%lf" , &n , &p))
    {
        FORR(i ,1 , n)
        {
            scanf("%d" , &a[i]);
        }
        a[0] = 0;
        sort(a , a + n + 1);
        ans = 1;
        FOR(i ,0 , n)
        {
            ans *= (1 - Count(a[i + 1] - a[i] - 1));
        }
        printf("%.7lf\n" , ans);
    }
    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值