HDOJ 4143

A Simple Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2670    Accepted Submission(s): 672


Problem Description
For a given positive integer n, please find the smallest positive integer x that we can find an integer y such that y^2 = n +x^2.
 

Input
The first line is an integer T, which is the the number of cases.
Then T line followed each containing an integer n (1<=n <= 10^9).
 

Output
For each integer n, please print output the x in a single line, if x does not exit , print -1 instead.
 

Sample Input
  
  
2 2 3
 

Sample Output
  
  
-1 1
 
一道思维题 。

由于数据范围很大(1<=n <= 10^9),所以直接暴力必TLE,因式分解y^2 = n +x^2得:(y-x)*(y+x)=n ,分解n , 一个因子y + x , 另一个 y - x , 因为(y + x) - (y - x) = 2 * y ,必为偶数  , 且两因子不同 。枚举其中一个因子从sqrt(n)到1。输出第一个符合条件的解即可!

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int main()
{
    //freopen("in.txt" , "r" , stdin);
    int T , n;
    cin >> T;
    while(T--)
    {
        cin >> n;
        int ok = 1;
        for(int i  = (int)sqrt(n) ; i >= 1 ; i--)
        {
            if(n % i == 0 && i != n / i && abs(i - n / i) % 2 == 0)
            {
                long long x = abs(i - n / i)  / 2;
                cout << x << endl;
                ok = 0;
                break;
            }
        }
        if(ok)printf("-1\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值