数据结构实验之二叉树七:叶子问题

数据结构实验之二叉树七:叶子问题

Time Limit: 1000MS Memory limit: 65536K

题目描述

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。

输入

 输入数据有多行,每一行是一个长度小于50个字符的字符串。

输出

 按从上到下从左到右的顺序输出二叉树的叶子结点。

示例输入

abd,,eg,,,cf,,,
xnl,,i,,u,,

示例输出

dfg
uli

提示

 

来源

 xam

示例程序

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
typedef struct node
{
    int data;
    struct node *lchild,*rchild;
}node;
int k;
node *creat(char str[])
{
    k++;
    node *root;
    if(str[k] == ',')
        root = NULL;
    else
    {
        root= (node *)malloc(sizeof(node));
        root->data = str[k];
        root->lchild = creat(str);
        root->rchild = creat(str);
    }
    return root;
}
void layer(node *root)
{
    int base = 0,top = 0;
    node *s[1000];
    s[top++] = root;
    while(top > base)
    {
        if(s[base])
        {
            root = s[base];
            if(root->lchild)
            {
                s[top++] = root->lchild;
            }
            if(root->rchild)
            {
                s[top++] = root->rchild;
            }
            if(!root->lchild && !root->rchild)
            {
                printf("%c",root->data);
            }
        }
        base++;
    }
}
int main()
{
    node *root;
    char str[1000];
    while(~scanf("%s",str))
    {
        k = -1;
        root = creat(str);
        layer(root);
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值