The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.
A binary search tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than the node's key.
- The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
- Both the left and right subtrees must also be binary search trees.
Given any two nodes in a BST, you are supposed to find their LCA.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.
Output Specification:
For each given pair of U and V, print in a line LCA of U and V is A.
if the LCA is found and A
is the key. But if A
is one of U and V, print X is an ancestor of Y.
where X
is A
and Y
is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found.
or ERROR: V is not found.
or ERROR: U and V are not found.
.
Sample Input:
6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99
Sample Output:
LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.
本题给的二叉树是二叉排序树的先序序列,如果uv在根的左右,那么此点符合要求。注意要从是第一个符合要求的点,先序:根左右
#include<iostream>
#include<map>
#include<vector>
#include<cstdio>
using namespace std;
int main(){
int m,n;
map<int,bool> mp;
cin >> m >> n;
vector<int> v(n+1);
for(int i =0;i < n;i++){
cin >> v[i];
mp[v[i]] = true;
}
while(m--){
int a,b;
cin >> a >> b;
bool flag = false;
int ans;
for(int i = 0;i < n;i++){
if(((v[i]>=a&&v[i]<=b)||(v[i]>=b&&v[i]<=a))&&mp[a]&&mp[b]){
flag = true;
ans = v[i];
break;
}
}
if(flag){
if(ans==a){
printf("%d is an ancestor of %d.\n",a,b);
}else if(ans==b){
printf("%d is an ancestor of %d.\n",b,a);
}else{
printf("LCA of %d and %d is %d.\n",a,b,ans);
}
}else{
if(mp[a]==false&&mp[b]==false){
printf("ERROR: %d and %d are not found.\n",a,b);
}else if(mp[a]==false){
printf("ERROR: %d is not found.\n",a);
}else if(mp[b]==false){
printf("ERROR: %d is not found.\n",b);
}
}
}
return 0;
}