1143 Lowest Common Ancestor (30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.
The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.
Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.
Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found…
Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题意:用先序遍历的方式给出一棵排序二叉树。让你回答n个询问。
找出每个询问的最近公共祖先。
思路:一般情况是先建立一棵树,完了之后就是用Lca。Lca有三种,使用树上倍
增,targain算法,dfs序列+RMQ算法。但是这个题目有点特殊,他是排序
二叉树,他有他自己的特性,其实就是二分,换而言之,对于给定的询问u
和v,我们在dfs遍历的第一个位于u,v之间的数,就是他们的最近公共祖先
为什么会是这样,这个和二叉树的特性有关,左子树一定小于等于根,右子
树一定大于根节点。我没办法证明,只能直观的理解一下。思路来自柳诺大
佬的博客。给出代码。其中set只是用来处理有些点不在这个树上。判重用
没其他用处。
代码:

#include<bits/stdc++.h>
#pragma GCC optimize(2)
#define MAXN 10010
#define maxnode 1000005
#define sigma_size 26
#define md 12345678
#define INF 0x3f3f3f3f
#define pii pair<int,int>
using namespace std;

int n,m;
int pp[MAXN];
set<int> kk;

int main()
{
    scanf("%d %d",&n,&m);
    for(int i=1;i<=m;i++)
        scanf("%d",&pp[i]),kk.insert(pp[i]);
    int u,v;
    for(int i=1;i<=n;i++)
    {
        scanf("%d %d",&u,&v);
        int aa;
        for(int j=1;j<=m;j++)
        {
            aa=pp[j];
            if(aa<=u&&aa>=v||aa<=v&&aa>=u)
                break;
        }
        if(!kk.count(u)&&!kk.count(v))
            printf("ERROR: %d and %d are not found.\n",u,v);
        else if(!kk.count(u)||!kk.count(v))
            printf("ERROR: %d is not found.\n",kk.count(u)==true?v:u);
        else if(u==aa||v==aa)
            printf("%d is an ancestor of %d.\n",u==aa?u:v,u==aa?v:u);
        else
            printf("LCA of %d and %d is %d.\n",u,v,aa);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值