HDU4925-Apple Tree

Apple Tree
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
   I’ve bought an orchard and decide to plant some apple trees on it. The orchard seems like an N * M two-dimensional map.  In each grid, I can either plant an apple tree to get one apple or fertilize the soil to speed up its neighbors’ production. When a grid is fertilized, the grid itself doesn’t produce apples but the number of apples of its four neighbor trees will double (if it exists). For example, an apple tree locates on (x, y), and (x - 1, y), (x, y - 1) are fertilized while (x + 1, y), (x, y + 1) are not, then I can get four apples from (x, y). Now, I am wondering how many apples I can get at most in the whole orchard?
 

Input
   The input contains multiple test cases. The number of test cases T (T<=100) occurs in the first line of input.   For each test case, two integers N, M (1<=N, M<=100) are given in a line, which denote the size of the map.
 

Output
   For each test case, you should output the maximum number of apples I can obtain.
 

Sample Input
2
2 2
3 3
 

Sample Output
8
32
 

 

 


//找规律,水题,但是是我第一次在多校联合赛上做出的第一道题,以此纪念
AC代码:

#include<stdio.h>
#include<string.h>
struct node
{
   int x;
   int v;
}a[110][110];
int max(int n,int m)
{
  return n>m?n:m;
}
int main()
{
   int i,j,n,m,T,sum1,sum2,Max;
   scanf("%d",&T);
   while(T--)
   {
       scanf("%d %d",&n,&m);
       sum1=0;sum2=0;
       memset(a,0,sizeof(a));
       for(i=1;i<=n;i++)
         for(j=1;j<=m;j++)
         {
            if(i%2!=0)
            {
               if(j%2!=0)
               a[i][j].x=1;
               else
               {
                  a[i][j].x=2;
                  a[i][j].v=1;
               }
            }
            else
            {
               if(j%2==0)
               a[i][j].x=1;
               else
               {
                  a[i][j].x=2;
                  a[i][j].v=1;
               }
            }
         }
      for(i=1;i<=n;i++)
         for(j=1;j<=m;j++)
         {
            if(a[i][j].x==2)
            {
               if(i-1>=1)
               {
                   a[i][j].v*=2;        
               }
               if(j-1>=1)
               {
                   a[i][j].v*=2;       
               }
               if(i+1<=n)
               {
                  a[i][j].v*=2;        
               }
               if(j+1<=m)
               {
                  a[i][j].v*=2; 
               }
            }                
         }
      for(i=1;i<=n;i++)
         for(j=1;j<=m;j++)
         if(a[i][j].x==2) sum1+=a[i][j].v;
         
         
      memset(a,0,sizeof(a));
      for(i=1;i<=n;i++)
         for(j=1;j<=m;j++)
         {
            if(i%2!=0)
            {
               if(j%2==0)
               a[i][j].x=1;
               else
               {
                  a[i][j].x=2;
                  a[i][j].v=1;
               }
            }
            else
            {
               if(j%2!=0)
               a[i][j].x=1;
               else
               {
                  a[i][j].x=2;
                  a[i][j].v=1;
               }
            }
         }
      for(i=1;i<=n;i++)
         for(j=1;j<=m;j++)
         {
            if(a[i][j].x==2)
            {
               if(i-1>=1)
               {
                  a[i][j].v*=2;        
               }
               if(j-1>=1)
               {
                   a[i][j].v*=2;       
               }
               if(i+1<=n)
               {
                  a[i][j].v*=2;        
               }
               if(j+1<=m)
               {
                  a[i][j].v*=2; 
               }
            }                
         }
      for(i=1;i<=n;i++)
         for(j=1;j<=m;j++)
         if(a[i][j].x==2) sum2+=a[i][j].v;
         
      Max=max(sum1,sum2);
      printf("%d\n",Max);
                         
   }
   return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

光仔December

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值