HDU 5264 pog loves szh I

Description

Pog has lots of strings. And he always mixes two equal-length strings. For example, there are two strings: "abcd" and "efgh". After mixing, a new string "aebfcgdh" is coming. 

However, szh thinks it is boring, so he reverses the second string, like changing "efgh" to "hgfe". Then mix them as usual, resulting in "ahbgcfde". 

Now, here comes a problem. Pog is given a string after mixing by szh, but he wants to find the original two strings. 

Hint : In this question, it needs a linefeed at the end of line at hack time.
 

Input

The first line has an integer, $T(1 \leq T \leq 100)$, indicating the number of cases. 

Then follows $T$ lines. Every lines has a string S, whose length is even and not more than $100$, and only consists of lower-case characters('a'~'z').
 

Output

For each cases, please output two lines, indicating two original strings.
 

Sample Input

    
    
1 aabbca
 

Sample Output

    
    
abc aba

非常水的题→_→ 数组分奇偶后 第二个字符串倒序输出

#include <iostream>
#include <string.h>
#include <map>
#include <stdio.h>
#include <algorithm>
using namespace std;

int main()
{
    char a[120];
    int T,len;
    scanf("%d",&T);
    for(int i=0; i<T; i++)
    {
        char b[100]= {0},c[100]= {0};
        scanf("%s",a);
        len=strlen(a);
        int x=0,y=0;
        for(int j=0; j<len; j++)
        {
            if(j%2==0)
            {
                b[x]=a[j];
                x++;
            }
            else
            {
                c[y]=a[j];
                y++;
            }
        }
        printf("%s\n",b);
        for(int j=y-1;j>=0;j--)
        {
            printf("%c",c[j]);
        }
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值