Description
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
Output
对应每组数据输出(A/B)%9973。
Sample Input
2 1000 53 87 123456789
Sample Output
7922 6060
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <map>
#include <set>
using namespace std;
//考察扩展欧几里德算法乘法逆元
int gcd(int a ,int b ,__int64 &x, __int64 &y)
{
if(b==0)
{
x=1;
y=0;
return a;
}
else
{
int r=gcd(b,a%b,y,x);
y-=x*(a/b);
return r;
}
}
int main()
{
int n,b,k=9973,t;
__int64 x,y;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&b);
gcd(b,k,x,y);
x=(x%k+k)%k;
x=(x*n)%9973;
printf("%I64d\n",x);
}
return 0;
}